{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:job-import-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1003015 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:job-import-plugin to 3.0 or later.","what":"CVE-2019-1003015 is a critical vulnerability in Jenkins Job Import Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1003015 and fix it if it is affected.\n\nWhat it is: CVE-2019-1003015 is a critical vulnerability in Jenkins Job Import Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-1003015 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:job-import-plugin (Maven): affected all versions; fixed in 3.0\n- org.jenkins-ci.plugins:job-import-plugin (Maven): affected all versions; fixed in 3.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1003015/ (Markdown: https://insights.sbomify.com/CVE-2019-1003015/index.md)","id":"CVE-2019-1003015","markdown":"https://insights.sbomify.com/CVE-2019-1003015/index.md","name":"CVE-2019-1003015","record":{"aliases":["GHSA-882r-r8fw-p538"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Job Import Plugin","requires_auth":"none","summary":"Attackers controlling the HTTP server can exploit XML external entity processing to read arbitrary files or cause denial of service.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"job_import","vendor":"jenkins"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"An XML external entity processing vulnerability exists in Jenkins Job Import Plugin 2.1 and earlier in src/main/java/org/jenkins/ci/plugins/jobimport/client/RestApiClient.java that allows attackers with the ability to control the HTTP server (Jenkins) queried in preparation of job import to read arbitrary files, perform a denial of service attack, etc.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XXE vulnerability in Jenkins Job Import Plugin","id":"CVE-2019-1003015","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xxe","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Job Import Plugin vulnerable to exposure of sensitive information","id":"CVE-2019-1003016"},"packages":[{"ecosystem":"Maven","fixed":["3.0"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:job-import-plugin","purl":null,"source":"GHSA-882r-r8fw-p538"},{"ecosystem":"Maven","fixed":["3.0"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:job-import-plugin","purl":"pkg:maven/org.jenkins-ci.plugins/job-import-plugin","source":"GHSA-882r-r8fw-p538"}],"prev":{"headline":"Jenkins Config File Provider Plugin XSS vulnerability","id":"CVE-2019-1003014"},"products":["Jenkins Job Import Plugin"],"published":"2019-02-06","related":[{"cvss_score":8.8,"headline":"Jenkins Job Import Plugin vulnerable to exposure of sensitive information","id":"CVE-2019-1003016","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":5.3,"headline":"Jenkins Job Import Plugin CSRF vulnerability","id":"CVE-2019-1003017","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":4.3,"headline":"Jenkins Job Import Plugin does not perform a permission check in an HTTP endpoint","id":"CVE-2026-48926","kev_date_added":null,"published":"2026-05-27"},{"cvss_score":4.3,"headline":"Jenkins Job Import Plugin allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins","id":"CVE-2022-43413","kev_date_added":null,"published":"2022-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Jenkins project"]},"summary":"Attackers controlling the HTTP server can exploit XML external entity processing to read arbitrary files or cause denial of service.","url":"https://insights.sbomify.com/CVE-2019-1003015/"}