# CVE-2019-1003015: XXE vulnerability in Jenkins Job Import Plugin

> Attackers controlling the HTTP server can exploit XML external entity processing to read arbitrary files or cause denial of service.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2019
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-882r-r8fw-p538

## What is CVE-2019-1003015?

CVE-2019-1003015 is a critical vulnerability in Jenkins Job Import Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

An XML external entity processing vulnerability exists in Jenkins Job Import Plugin 2.1 and earlier in src/main/java/org/jenkins/ci/plugins/jobimport/client/RestApiClient.java that allows attackers with the ability to control the HTTP server (Jenkins) queried in preparation of job import to read arbitrary files, perform a denial of service attack, etc.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2019-1003015?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:job-import-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:job-import-plugin` | Maven | All versions | 3.0 |
| `org.jenkins-ci.plugins:job-import-plugin` | Maven | All versions | 3.0 |

Products: Jenkins Job Import.

## How do I fix CVE-2019-1003015?

Upgrade org.jenkins-ci.plugins:job-import-plugin to 3.0 or later.

## Is CVE-2019-1003015 being exploited?

There is no known exploitation of CVE-2019-1003015 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Job Import Plugin

- [CVE-2019-1003016](https://insights.sbomify.com/CVE-2019-1003016/): Jenkins Job Import Plugin vulnerable to exposure of sensitive information (high 8.8)
- [CVE-2019-1003017](https://insights.sbomify.com/CVE-2019-1003017/): Jenkins Job Import Plugin CSRF vulnerability (medium 5.3)
- [CVE-2026-48926](https://insights.sbomify.com/CVE-2026-48926/): Jenkins Job Import Plugin does not perform a permission check in an HTTP endpoint (medium 4.3)
- [CVE-2022-43413](https://insights.sbomify.com/CVE-2022-43413/): Jenkins Job Import Plugin allows attackers with Overall/Read permission to enumerate credentials IDs of credentials stored in Jenkins (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003015 and fix it if it is affected.

What it is: CVE-2019-1003015 is a critical vulnerability in Jenkins Job Import Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003015 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:job-import-plugin (Maven): affected all versions; fixed in 3.0
- org.jenkins-ci.plugins:job-import-plugin (Maven): affected all versions; fixed in 3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003015/ (Markdown: https://insights.sbomify.com/CVE-2019-1003015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003015
- OSV: https://osv.dev/vulnerability/CVE-2019-1003015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003015/
Summaries are generated and may contain mistakes; the official description above is the record.
