{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:kanboard. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1003020 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:kanboard to 1.5.11 or later.","what":"CVE-2019-1003020 is a medium-severity server-side request forgery vulnerability in Jenkins Kanboard Plugin, published on 6 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1003020 and fix it if it is affected.\n\nWhat it is: CVE-2019-1003020 is a medium-severity server-side request forgery vulnerability in Jenkins Kanboard Plugin, published on 6 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-1003020 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:kanboard (Maven): affected all versions; fixed in 1.5.11\n- org.jenkins-ci.plugins:kanboard (Maven): affected all versions; fixed in 1.5.11\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1003020/ (Markdown: https://insights.sbomify.com/CVE-2019-1003020/index.md)","id":"CVE-2019-1003020","markdown":"https://insights.sbomify.com/CVE-2019-1003020/index.md","name":"CVE-2019-1003020","record":{"aliases":["GHSA-278v-j3cr-jv2x"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Kanboard Plugin","requires_auth":"low_privilege","summary":"Attackers with read permissions can force the Jenkins Kanboard plugin to send requests to arbitrary URLs, potentially accessing internal resources.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"kanboard","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A server-side request forgery vulnerability exists in Jenkins Kanboard Plugin 1.5.10 and earlier in KanboardGlobalConfiguration.java that allows attackers with Overall/Read permission to submit a GET request to an attacker-specified URL.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Kanboard Plugin vulnerable to Server-side request forgery (SSRF)","id":"CVE-2019-1003020","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins OpenId Connect Authentication Plugin showed plain text client secret in configuration form","id":"CVE-2019-1003021"},"packages":[{"ecosystem":"Maven","fixed":["1.5.11"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:kanboard","purl":null,"source":"GHSA-278v-j3cr-jv2x"},{"ecosystem":"Maven","fixed":["1.5.11"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:kanboard","purl":"pkg:maven/org.jenkins-ci.plugins/kanboard","source":"GHSA-278v-j3cr-jv2x"}],"prev":{"headline":"GitHub Authentication Plugin session fixation vulnerability","id":"CVE-2019-1003019"},"products":["Jenkins Kanboard Plugin"],"published":"2019-02-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Jenkins project"]},"summary":"Attackers with read permissions can force the Jenkins Kanboard plugin to send requests to arbitrary URLs, potentially accessing internal resources.","url":"https://insights.sbomify.com/CVE-2019-1003020/"}