# CVE-2019-1003020: Jenkins Kanboard Plugin vulnerable to Server-side request forgery (SSRF)

> Attackers with read permissions can force the Jenkins Kanboard plugin to send requests to arbitrary URLs, potentially accessing internal resources.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Feb 2019
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-278v-j3cr-jv2x

## What is CVE-2019-1003020?

CVE-2019-1003020 is a medium-severity server-side request forgery vulnerability in Jenkins Kanboard Plugin, published on 6 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A server-side request forgery vulnerability exists in Jenkins Kanboard Plugin 1.5.10 and earlier in KanboardGlobalConfiguration.java that allows attackers with Overall/Read permission to submit a GET request to an attacker-specified URL.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2019-1003020?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:kanboard. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:kanboard` | Maven | All versions | 1.5.11 |
| `org.jenkins-ci.plugins:kanboard` | Maven | All versions | 1.5.11 |

Products: Jenkins Kanboard.

## How do I fix CVE-2019-1003020?

Upgrade org.jenkins-ci.plugins:kanboard to 1.5.11 or later.

## Is CVE-2019-1003020 being exploited?

There is no known exploitation of CVE-2019-1003020 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003020 and fix it if it is affected.

What it is: CVE-2019-1003020 is a medium-severity server-side request forgery vulnerability in Jenkins Kanboard Plugin, published on 6 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003020 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:kanboard (Maven): affected all versions; fixed in 1.5.11
- org.jenkins-ci.plugins:kanboard (Maven): affected all versions; fixed in 1.5.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003020/ (Markdown: https://insights.sbomify.com/CVE-2019-1003020/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003020
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003020
- OSV: https://osv.dev/vulnerability/CVE-2019-1003020

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003020/
Summaries are generated and may contain mistakes; the official description above is the record.
