{"answers":{"affected":"2 open source packages ship an affected version, including org.jvnet.hudson.plugins:monitoring. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1003022 in the wild and no public exploit code.","fix":"Upgrade org.jvnet.hudson.plugins:monitoring to 1.75.0 or later.","what":"CVE-2019-1003022 is a medium-severity denial of service vulnerability in Jenkins Monitoring Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-1003022 and fix it if it is affected.\n\nWhat it is: CVE-2019-1003022 is a medium-severity denial of service vulnerability in Jenkins Monitoring Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-1003022 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jvnet.hudson.plugins:monitoring (Maven): affected all versions; fixed in 1.75.0\n- org.jvnet.hudson.plugins:monitoring (Maven): affected all versions; fixed in 1.75.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1003022/ (Markdown: https://insights.sbomify.com/CVE-2019-1003022/index.md)","id":"CVE-2019-1003022","markdown":"https://insights.sbomify.com/CVE-2019-1003022/index.md","name":"CVE-2019-1003022","record":{"aliases":["GHSA-hw83-jpxr-g225"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Monitoring Plugin","requires_auth":"none","summary":"Attackers can cause a denial of service by killing threads on the Jenkins master via the Monitoring Plugin.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"monitoring","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"A denial of service vulnerability exists in Jenkins Monitoring Plugin 1.74.0 and earlier in PluginImpl.java that allows attackers to kill threads running on the Jenkins master.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Monitoring Plugin vulnerable to Denial of service vulnerability","id":"CVE-2019-1003022","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"XSS vulnerability in Jenkins Warnings Next Generation Plugin","id":"CVE-2019-1003023"},"packages":[{"ecosystem":"Maven","fixed":["1.75.0"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:monitoring","purl":null,"source":"GHSA-hw83-jpxr-g225"},{"ecosystem":"Maven","fixed":["1.75.0"],"introduced":["0"],"last_affected":[],"package":"org.jvnet.hudson.plugins:monitoring","purl":"pkg:maven/org.jvnet.hudson.plugins/monitoring","source":"GHSA-hw83-jpxr-g225"}],"prev":{"headline":"Jenkins OpenId Connect Authentication Plugin showed plain text client secret in configuration form","id":"CVE-2019-1003021"},"products":["Jenkins Monitoring Plugin"],"published":"2019-02-06","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Jenkins project"]},"summary":"Attackers can cause a denial of service by killing threads on the Jenkins master via the Monitoring Plugin.","url":"https://insights.sbomify.com/CVE-2019-1003022/"}