{"answers":{"affected":"2 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1003023 in the wild and no public exploit code.","fix":"Upgrade io.jenkins.plugins:warnings-ng to 2.0.0 or later.","what":"CVE-2019-1003023 is a medium-severity cross-site scripting vulnerability in Jenkins Warnings Next Generation Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-1003023 and fix it if it is affected.\n\nWhat it is: CVE-2019-1003023 is a medium-severity cross-site scripting vulnerability in Jenkins Warnings Next Generation Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-1003023 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 2.0.0\n- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1003023/ (Markdown: https://insights.sbomify.com/CVE-2019-1003023/index.md)","id":"CVE-2019-1003023","markdown":"https://insights.sbomify.com/CVE-2019-1003023/index.md","name":"CVE-2019-1003023","record":{"aliases":["GHSA-cqp7-hwm3-cfg7"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins plugin","requires_auth":"none","summary":"Attackers controlling parser input can inject arbitrary HTML into Jenkins, potentially leading to session hijacking or malicious script execution.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"warnings_next_generation","vendor":"jenkins"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"A cross-site scripting vulnerability exists in Jenkins Warnings Next Generation Plugin 1.0.1 and earlier in src/main/java/io/jenkins/plugins/analysis/core/model/DetailsTableModel.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourceDetail.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourcePrinter.java, src/main/java/io/jenkins/plugins/analysis/core/util/Sanitizer.java, src/main/java/io/jenkins/plugins/analysis/warnings/DuplicateCodeScanner.java that allows attackers with the ability to control warnings parser input to have Jenkins render arbitrary HTML.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"XSS vulnerability in Jenkins Warnings Next Generation Plugin","id":"CVE-2019-1003023","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Script Security Plugin sandbox bypass vulnerability","id":"CVE-2019-1003024"},"packages":[{"ecosystem":"Maven","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":null,"source":"GHSA-cqp7-hwm3-cfg7"},{"ecosystem":"Maven","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"io.jenkins.plugins:warnings-ng","purl":"pkg:maven/io.jenkins.plugins/warnings-ng","source":"GHSA-cqp7-hwm3-cfg7"}],"prev":{"headline":"Jenkins Monitoring Plugin vulnerable to Denial of service vulnerability","id":"CVE-2019-1003022"},"products":["Jenkins Warnings Next Generation Plugin"],"published":"2019-02-06","related":[{"cvss_score":8.8,"headline":"Jenkins Warnings Next Generation Plugin cross-site request forgery vulnerability","id":"CVE-2019-1003008","kev_date_added":null,"published":"2019-02-06"},{"cvss_score":8.1,"headline":"Path Traversal in Jenkins Warnings Next Generation Plugin","id":"CVE-2022-23107","kev_date_added":null,"published":"2022-01-12"},{"cvss_score":5.4,"headline":"Jenkins Warnings NG Plugin Cross-site scripting vulnerability","id":"CVE-2019-10325","kev_date_added":null,"published":"2019-05-31"},{"cvss_score":4.3,"headline":"Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents","id":"CVE-2021-21626","kev_date_added":null,"published":"2021-03-18"},{"cvss_score":4.3,"headline":"Jenkins Warnings NG Plugin cross-site request forgery vulnerability","id":"CVE-2019-10326","kev_date_added":null,"published":"2019-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Jenkins project"]},"summary":"Attackers controlling parser input can inject arbitrary HTML into Jenkins, potentially leading to session hijacking or malicious script execution.","url":"https://insights.sbomify.com/CVE-2019-1003023/"}