# CVE-2019-1003023: XSS vulnerability in Jenkins Warnings Next Generation Plugin

> Attackers controlling parser input can inject arbitrary HTML into Jenkins, potentially leading to session hijacking or malicious script execution.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 6 Feb 2019
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-cqp7-hwm3-cfg7

## What is CVE-2019-1003023?

CVE-2019-1003023 is a medium-severity cross-site scripting vulnerability in Jenkins Warnings Next Generation Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site scripting vulnerability exists in Jenkins Warnings Next Generation Plugin 1.0.1 and earlier in src/main/java/io/jenkins/plugins/analysis/core/model/DetailsTableModel.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourceDetail.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourcePrinter.java, src/main/java/io/jenkins/plugins/analysis/core/util/Sanitizer.java, src/main/java/io/jenkins/plugins/analysis/warnings/DuplicateCodeScanner.java that allows attackers with the ability to control warnings parser input to have Jenkins render arbitrary HTML.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-1003023?

2 open source packages ship an affected version, including io.jenkins.plugins:warnings-ng. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.jenkins.plugins:warnings-ng` | Maven | All versions | 2.0.0 |
| `io.jenkins.plugins:warnings-ng` | Maven | All versions | 2.0.0 |

Products: Jenkins Warnings Next Generation.

## How do I fix CVE-2019-1003023?

Upgrade io.jenkins.plugins:warnings-ng to 2.0.0 or later.

## Is CVE-2019-1003023 being exploited?

There is no known exploitation of CVE-2019-1003023 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Warnings Next Generation Plugin

- [CVE-2019-1003008](https://insights.sbomify.com/CVE-2019-1003008/): Jenkins Warnings Next Generation Plugin cross-site request forgery vulnerability (high 8.8)
- [CVE-2022-23107](https://insights.sbomify.com/CVE-2022-23107/): Path Traversal in Jenkins Warnings Next Generation Plugin (high 8.1)
- [CVE-2019-10325](https://insights.sbomify.com/CVE-2019-10325/): Jenkins Warnings NG Plugin Cross-site scripting vulnerability (medium 5.4)
- [CVE-2021-21626](https://insights.sbomify.com/CVE-2021-21626/): Missing permission checks in Jenkins Warnings Next Generation Plugin allow listing workspace contents (medium 4.3)
- [CVE-2019-10326](https://insights.sbomify.com/CVE-2019-10326/): Jenkins Warnings NG Plugin cross-site request forgery vulnerability (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003023 and fix it if it is affected.

What it is: CVE-2019-1003023 is a medium-severity cross-site scripting vulnerability in Jenkins Warnings Next Generation Plugin, published on 6 Feb 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-1003023 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 2.0.0
- io.jenkins.plugins:warnings-ng (Maven): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003023/ (Markdown: https://insights.sbomify.com/CVE-2019-1003023/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003023
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003023
- OSV: https://osv.dev/vulnerability/CVE-2019-1003023

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003023/
Summaries are generated and may contain mistakes; the official description above is the record.
