{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:cloudfoundry. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1003025 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:cloudfoundry to 2.3.2 or later.","what":"CVE-2019-1003025 is a high-severity vulnerability in Jenkins Cloud Foundry Plugin, published on 20 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1003025 and fix it if it is affected.\n\nWhat it is: CVE-2019-1003025 is a high-severity vulnerability in Jenkins Cloud Foundry Plugin, published on 20 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-1003025 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:cloudfoundry (Maven): affected all versions; fixed in 2.3.2\n- org.jenkins-ci.plugins:cloudfoundry (Maven): affected all versions; fixed in 2.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1003025/ (Markdown: https://insights.sbomify.com/CVE-2019-1003025/index.md)","id":"CVE-2019-1003025","markdown":"https://insights.sbomify.com/CVE-2019-1003025/index.md","name":"CVE-2019-1003025","record":{"aliases":["GHSA-2mh9-wpgv-7xr8"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Cloud Foundry Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can capture stored credentials by connecting to a malicious URL via the Jenkins Cloud Foundry Plugin.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"cloud_foundry","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"A exposure of sensitive information vulnerability exists in Jenkins Cloud Foundry Plugin 2.3.1 and earlier in AbstractCloudFoundryPushDescriptor.java that allows attackers with Overall/Read access to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Cloud Foundry Plugin vulnerable to exposure of sensitive information","id":"CVE-2019-1003025","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"information_disclosure","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"Jenkins Mattermost Notification Plugin vulnerable to SSRF","id":"CVE-2019-1003026"},"packages":[{"ecosystem":"Maven","fixed":["2.3.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:cloudfoundry","purl":null,"source":"GHSA-2mh9-wpgv-7xr8"},{"ecosystem":"Maven","fixed":["2.3.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:cloudfoundry","purl":"pkg:maven/org.jenkins-ci.plugins/cloudfoundry","source":"GHSA-2mh9-wpgv-7xr8"}],"prev":{"headline":"Jenkins Script Security Plugin sandbox bypass vulnerability","id":"CVE-2019-1003024"},"products":["Jenkins Cloud Foundry Plugin"],"published":"2019-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Jenkins project"]},"summary":"Attackers with read access can capture stored credentials by connecting to a malicious URL via the Jenkins Cloud Foundry Plugin.","url":"https://insights.sbomify.com/CVE-2019-1003025/"}