{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:mattermost. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1003026 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:mattermost to 2.6.3 or later.","what":"CVE-2019-1003026 is a medium-severity server-side request forgery vulnerability in Jenkins Mattermost Notification Plugin, published on 20 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1003026 and fix it if it is affected.\n\nWhat it is: CVE-2019-1003026 is a medium-severity server-side request forgery vulnerability in Jenkins Mattermost Notification Plugin, published on 20 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-1003026 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:mattermost (Maven): affected all versions; fixed in 2.6.3\n- org.jenkins-ci.plugins:mattermost (Maven): affected all versions; fixed in 2.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1003026/ (Markdown: https://insights.sbomify.com/CVE-2019-1003026/index.md)","id":"CVE-2019-1003026","markdown":"https://insights.sbomify.com/CVE-2019-1003026/index.md","name":"CVE-2019-1003026","record":{"aliases":["GHSA-wxj2-qc9p-65r3"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_read","other"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Mattermost Plugin","requires_auth":"low_privilege","summary":"Attackers with read permissions can force Jenkins to connect to arbitrary Mattermost servers and send messages via the notification plugin.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"mattermost","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"A server-side request forgery vulnerability exists in Jenkins Mattermost Notification Plugin 2.6.2 and earlier in MattermostNotifier.java that allows attackers with Overall/Read permission to have Jenkins connect to an attacker-specified Mattermost server and room and send a message.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins Mattermost Notification Plugin vulnerable to SSRF","id":"CVE-2019-1003026","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2019"},"n_packages":2,"n_references":2,"next":{"headline":"SSRF vulnerability due to missing permission check in Jenkins OctopusDeploy Plugin","id":"CVE-2019-1003027"},"packages":[{"ecosystem":"Maven","fixed":["2.6.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:mattermost","purl":null,"source":"GHSA-wxj2-qc9p-65r3"},{"ecosystem":"Maven","fixed":["2.6.3"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:mattermost","purl":"pkg:maven/org.jenkins-ci.plugins/mattermost","source":"GHSA-wxj2-qc9p-65r3"}],"prev":{"headline":"Jenkins Cloud Foundry Plugin vulnerable to exposure of sensitive information","id":"CVE-2019-1003025"},"products":["Jenkins Mattermost Notification Plugin"],"published":"2019-02-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["Jenkins project"]},"summary":"Attackers with read permissions can force Jenkins to connect to arbitrary Mattermost servers and send messages via the notification plugin.","url":"https://insights.sbomify.com/CVE-2019-1003026/"}