# CVE-2019-1003026: Jenkins Mattermost Notification Plugin vulnerable to SSRF

> Attackers with read permissions can force Jenkins to connect to arbitrary Mattermost servers and send messages via the notification plugin.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-wxj2-qc9p-65r3

## What is CVE-2019-1003026?

CVE-2019-1003026 is a medium-severity server-side request forgery vulnerability in Jenkins Mattermost Notification Plugin, published on 20 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A server-side request forgery vulnerability exists in Jenkins Mattermost Notification Plugin 2.6.2 and earlier in MattermostNotifier.java that allows attackers with Overall/Read permission to have Jenkins connect to an attacker-specified Mattermost server and room and send a message.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2019-1003026?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:mattermost. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:mattermost` | Maven | All versions | 2.6.3 |
| `org.jenkins-ci.plugins:mattermost` | Maven | All versions | 2.6.3 |

Products: Jenkins Mattermost.

## How do I fix CVE-2019-1003026?

Upgrade org.jenkins-ci.plugins:mattermost to 2.6.3 or later.

## Is CVE-2019-1003026 being exploited?

There is no known exploitation of CVE-2019-1003026 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003026 and fix it if it is affected.

What it is: CVE-2019-1003026 is a medium-severity server-side request forgery vulnerability in Jenkins Mattermost Notification Plugin, published on 20 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003026 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:mattermost (Maven): affected all versions; fixed in 2.6.3
- org.jenkins-ci.plugins:mattermost (Maven): affected all versions; fixed in 2.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003026/ (Markdown: https://insights.sbomify.com/CVE-2019-1003026/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003026
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003026
- OSV: https://osv.dev/vulnerability/CVE-2019-1003026

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003026/
Summaries are generated and may contain mistakes; the official description above is the record.
