# CVE-2019-1003027: SSRF vulnerability due to missing permission check in Jenkins OctopusDeploy Plugin

> Attackers with read permissions can force Jenkins to connect to arbitrary URLs, potentially exposing internal network details or response codes.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-5v2j-w677-j4mp

## What is CVE-2019-1003027?

CVE-2019-1003027 is a medium-severity server-side request forgery vulnerability in Jenkins OctopusDeploy Plugin, published on 20 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A server-side request forgery vulnerability exists in Jenkins OctopusDeploy Plugin 1.8.1 and earlier in OctopusDeployPlugin.java that allows attackers with Overall/Read permission to have Jenkins connect to an attacker-specified URL and obtain the HTTP response code if successful, and exception error message otherwise.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2019-1003027?

2 open source packages ship an affected version, including hudson.plugins.octopusdeploy:octopusdeploy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hudson.plugins.octopusdeploy:octopusdeploy` | Maven | All versions | 1.9.0 |
| `hudson.plugins.octopusdeploy:octopusdeploy` | Maven | All versions | 1.9.0 |

Products: Jenkins Octopusdeploy.

## How do I fix CVE-2019-1003027?

Upgrade hudson.plugins.octopusdeploy:octopusdeploy to 1.9.0 or later.

## Is CVE-2019-1003027 being exploited?

There is no known exploitation of CVE-2019-1003027 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins OctopusDeploy Plugin

- [CVE-2019-1003071](https://insights.sbomify.com/CVE-2019-1003071/): Jenkins Octopus Deploy Plugin stores credentials in plain text (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003027 and fix it if it is affected.

What it is: CVE-2019-1003027 is a medium-severity server-side request forgery vulnerability in Jenkins OctopusDeploy Plugin, published on 20 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003027 in the wild and no public exploit code.

Affected packages and fixed versions:
- hudson.plugins.octopusdeploy:octopusdeploy (Maven): affected all versions; fixed in 1.9.0
- hudson.plugins.octopusdeploy:octopusdeploy (Maven): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003027/ (Markdown: https://insights.sbomify.com/CVE-2019-1003027/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003027
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003027
- OSV: https://osv.dev/vulnerability/CVE-2019-1003027

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003027/
Summaries are generated and may contain mistakes; the official description above is the record.
