# CVE-2019-1003028: SSRF vulnerability due to missing permission check in Jenkins JMS Messaging Plugin

> Attackers with Read permission can force Jenkins to connect to arbitrary JMS endpoints, enabling server-side request forgery attacks.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Feb 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-g3gj-632x-fhrh

## What is CVE-2019-1003028?

CVE-2019-1003028 is a medium-severity server-side request forgery vulnerability in Jenkins JMS Messaging Plugin, published on 20 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A server-side request forgery vulnerability exists in Jenkins JMS Messaging Plugin 1.1.1 and earlier in SSLCertificateAuthenticationMethod.java, UsernameAuthenticationMethod.java that allows attackers with Overall/Read permission to have Jenkins connect to a JMS endpoint.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2019-1003028?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:jms-messaging. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:jms-messaging` | Maven | All versions | 1.1.2 |
| `org.jenkins-ci.plugins:jms-messaging` | Maven | All versions | 1.1.2 |

Products: Jenkins Jms Messaging.

## How do I fix CVE-2019-1003028?

Upgrade org.jenkins-ci.plugins:jms-messaging to 1.1.2 or later.

## Is CVE-2019-1003028 being exploited?

There is no known exploitation of CVE-2019-1003028 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003028 and fix it if it is affected.

What it is: CVE-2019-1003028 is a medium-severity server-side request forgery vulnerability in Jenkins JMS Messaging Plugin, published on 20 Feb 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003028 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:jms-messaging (Maven): affected all versions; fixed in 1.1.2
- org.jenkins-ci.plugins:jms-messaging (Maven): affected all versions; fixed in 1.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003028/ (Markdown: https://insights.sbomify.com/CVE-2019-1003028/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003028
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003028
- OSV: https://osv.dev/vulnerability/CVE-2019-1003028

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003028/
Summaries are generated and may contain mistakes; the official description above is the record.
