# CVE-2019-1003029: Jenkins Script Security Plugin Sandbox Bypass

> Attackers with read permissions can execute arbitrary code on the Jenkins master via a sandbox bypass in the Script Security Plugin.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 25 Apr 2022 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2019
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-xvxq-hq48-xphm

## What is CVE-2019-1003029?

CVE-2019-1003029 is a critical code injection vulnerability in Redhat Openshift Container Platform, published on 8 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A sandbox bypass vulnerability exists in Jenkins Script Security Plugin 1.53 and earlier in src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/GroovySandbox.java, src/main/java/org/jenkinsci/plugins/scriptsecurity/sandbox/groovy/SecureGroovyScript.java that allows attackers with Overall/Read permission to execute arbitrary code on the Jenkins master JVM.

## Which versions are affected by CVE-2019-1003029?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:script-security. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.54 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.54 |

Products: Jenkins Script Security, Redhat Openshift Container Platform.

## How do I fix CVE-2019-1003029?

Upgrade org.jenkins-ci.plugins:script-security to 1.54 or later. US federal agencies must fix it by 16 May 2022.

## Is CVE-2019-1003029 being exploited?

Yes. Attackers have exploited CVE-2019-1003029 in the wild since at least 25 Apr 2022.

Public exploit code:

- Jenkins ACL Bypass and Metaprogramming RCE (metasploit)

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2022-43401](https://insights.sbomify.com/CVE-2022-43401/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2022-43403](https://insights.sbomify.com/CVE-2022-43403/): Jenkins Script Security Plugin sandbox bypass vulnerability (critical 9.9)
- [CVE-2022-43404](https://insights.sbomify.com/CVE-2022-43404/): Sandbox bypass vulnerabilities in Jenkins Script Security Plugin and in Pipeline: Groovy Plugin (critical 9.9)
- [CVE-2020-2279](https://insights.sbomify.com/CVE-2020-2279/): Sandbox bypass vulnerability in Jenkins Script Security Plugin (critical 9.9)
- [CVE-2019-10431](https://insights.sbomify.com/CVE-2019-10431/): Improper Control of Generation of Code in Jenkins Script Security Plugin (critical 9.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003029 and fix it if it is affected.

What it is: CVE-2019-1003029 is a critical code injection vulnerability in Redhat Openshift Container Platform, published on 8 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2019-1003029 in the wild since at least 25 Apr 2022.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.54
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.54

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003029/ (Markdown: https://insights.sbomify.com/CVE-2019-1003029/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003029
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003029
- OSV: https://osv.dev/vulnerability/CVE-2019-1003029

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003029/
Summaries are generated and may contain mistakes; the official description above is the record.
