# CVE-2019-1003030: Jenkins Matrix Project Plugin Remote Code Execution

> Attackers controlling pipeline scripts can bypass the sandbox to execute arbitrary code on the Jenkins master JVM.

- **Severity:** Critical 9.9 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 25 Mar 2022 (CISA KEV)
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2019
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-r6mc-mrvr-23cr

## What is CVE-2019-1003030?

CVE-2019-1003030 is a critical vulnerability in Redhat Openshift Container Platform, published on 8 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A sandbox bypass vulnerability exists in Jenkins Pipeline: Groovy Plugin 2.63 and earlier in pom.xml, src/main/java/org/jenkinsci/plugins/workflow/cps/CpsGroovyShell.java that allows attackers able to control pipeline scripts to execute arbitrary code on the Jenkins master JVM.

Weakness: CWE-693 (Protection Mechanism Failure)

## Which versions are affected by CVE-2019-1003030?

2 open source packages ship an affected version, including org.jenkins-ci.plugins.workflow:workflow-cps. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins.workflow:workflow-cps` | Maven | All versions | 2.64 |
| `org.jenkins-ci.plugins.workflow:workflow-cps` | Maven | All versions | 2.64 |

Products: Jenkins Pipeline\, Redhat Openshift Container Platform.

## How do I fix CVE-2019-1003030?

Upgrade org.jenkins-ci.plugins.workflow:workflow-cps to 2.64 or later. US federal agencies must fix it by 15 Apr 2022.

## Is CVE-2019-1003030 being exploited?

Yes. Attackers have exploited CVE-2019-1003030 in the wild since at least 25 Mar 2022.

Public exploit code:

- https://github.com/overgrowncarrot1/CVE-2019-1003030 (github_poc): https://github.com/overgrowncarrot1/CVE-2019-1003030
- Jenkins 2.63 - Sandbox bypass in pipeline: Groovy plug-in (exploitdb)
- PoC for jenkins 2.63 CVE-2019-1003030 (github_poc): https://github.com/cyberbelly/PoC-CVE-2019-1003030
- Jenkins Pipeline Groovy Plugin <=2.63 - Insecure Deserialization (nuclei): http/cves/2019/CVE-2019-1003030.yaml

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2022-43402](https://insights.sbomify.com/CVE-2022-43402/): Jenkins Pipeline: Groovy Plugin allows sandbox protection bypass and arbitrary code execution (critical 9.9)
- [CVE-2019-1003041](https://insights.sbomify.com/CVE-2019-1003041/): Sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin (critical 9.8)
- [CVE-2022-43407](https://insights.sbomify.com/CVE-2022-43407/): CSRF protection for any URL can be bypassed in Jenkins Pipeline: Input Step Plugin (high 8.8)
- [CVE-2022-25173](https://insights.sbomify.com/CVE-2022-25173/): Improper Neutralization of Special Elements used in an OS Command in Jenkins Pipeline: Groovy Plugin (high 8.8)
- [CVE-2022-25174](https://insights.sbomify.com/CVE-2022-25174/): Improper Neutralization of Special Elements used in an OS Command in Jenkins Pipeline: Shared Groovy Libraries Plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003030 and fix it if it is affected.

What it is: CVE-2019-1003030 is a critical vulnerability in Redhat Openshift Container Platform, published on 8 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2019-1003030 in the wild since at least 25 Mar 2022.

Affected packages and fixed versions:
- org.jenkins-ci.plugins.workflow:workflow-cps (Maven): affected all versions; fixed in 2.64
- org.jenkins-ci.plugins.workflow:workflow-cps (Maven): affected all versions; fixed in 2.64

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003030/ (Markdown: https://insights.sbomify.com/CVE-2019-1003030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003030
- OSV: https://osv.dev/vulnerability/CVE-2019-1003030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003030/
Summaries are generated and may contain mistakes; the official description above is the record.
