# CVE-2019-1003038: Jenkins Repository Connector Plugin has insufficiently protected credentials

> An attacker with local access or browser control can retrieve stored passwords from the Jenkins Repository Connector Plugin configuration.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Mar 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-99jc-v8pq-6qm4

## What is CVE-2019-1003038?

CVE-2019-1003038 is a high-severity vulnerability in Jenkins Repository Connector Plugin, published on 8 Mar 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

An insufficiently protected credentials vulnerability exists in Jenkins Repository Connector Plugin 1.2.4 and earlier in src/main/java/org/jvnet/hudson/plugins/repositoryconnector/ArtifactDeployer.java, src/main/java/org/jvnet/hudson/plugins/repositoryconnector/Repository.java, src/main/java/org/jvnet/hudson/plugins/repositoryconnector/UserPwd.java that allows an attacker with local file system access or control of a Jenkins administrator's web browser (e.g. malicious extension) to retrieve the password stored in the plugin configuration.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2019-1003038?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:repository-connector. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:repository-connector` | Maven | All versions | 1.2.5 |
| `org.jenkins-ci.plugins:repository-connector` | Maven | All versions | 1.2.5 |

Products: Jenkins Repository Connector.

## How do I fix CVE-2019-1003038?

Upgrade org.jenkins-ci.plugins:repository-connector to 1.2.5 or later.

## Is CVE-2019-1003038 being exploited?

There is no known exploitation of CVE-2019-1003038 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Repository Connector Plugin

- [CVE-2022-34195](https://insights.sbomify.com/CVE-2022-34195/): Cross-site Scripting in Jenkins Repository Connector Plugin (medium 5.4)
- [CVE-2021-21618](https://insights.sbomify.com/CVE-2021-21618/): Stored XSS vulnerability in Jenkins Repository Connector Plugin (medium 5.4)
- [CVE-2020-2149](https://insights.sbomify.com/CVE-2020-2149/): Credentials transmitted in plain text by Repository Connector Plugin (medium 5.3)
- [CVE-2022-36903](https://insights.sbomify.com/CVE-2022-36903/): Jenkins Repository Connector Plugin allows attackers with Overall/Read permission to enumerate credentials IDs (medium 4.3)
- [CVE-2022-36904](https://insights.sbomify.com/CVE-2022-36904/): Jenkins Repository Connector Plugin does not perform a permission check in a method implementing form validation (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003038 and fix it if it is affected.

What it is: CVE-2019-1003038 is a high-severity vulnerability in Jenkins Repository Connector Plugin, published on 8 Mar 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003038 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:repository-connector (Maven): affected all versions; fixed in 1.2.5
- org.jenkins-ci.plugins:repository-connector (Maven): affected all versions; fixed in 1.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003038/ (Markdown: https://insights.sbomify.com/CVE-2019-1003038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003038
- OSV: https://osv.dev/vulnerability/CVE-2019-1003038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003038/
Summaries are generated and may contain mistakes; the official description above is the record.
