# CVE-2019-1003042: Jenkins Lockable Resources Plugin XSS vulnerability

> Attackers controlling resource names can inject arbitrary JavaScript into Jenkins web pages via the Lockable Resources Plugin.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Mar 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-wqjj-c9cx-q7cf

## What is CVE-2019-1003042?

CVE-2019-1003042 is a medium-severity cross-site scripting vulnerability in Jenkins Lockable Resources Plugin, published on 28 Mar 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A cross site scripting vulnerability in Jenkins Lockable Resources Plugin 2.4 and earlier allows attackers able to control resource names to inject arbitrary JavaScript in web pages rendered by the plugin.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-1003042?

2 open source packages ship an affected version, including org.6wind.jenkins:lockable-resources. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.6wind.jenkins:lockable-resources` | Maven | All versions | 2.5 |
| `org.6wind.jenkins:lockable-resources` | Maven | All versions | 2.5 |

Products: Jenkins Lockable Resources.

## How do I fix CVE-2019-1003042?

Upgrade org.6wind.jenkins:lockable-resources to 2.5 or later.

## Is CVE-2019-1003042 being exploited?

There is no known exploitation of CVE-2019-1003042 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Lockable Resources Plugin

- [CVE-2020-2281](https://insights.sbomify.com/CVE-2020-2281/): CSRF vulnerability in Jenkins Lockable Resources Plugin (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003042 and fix it if it is affected.

What it is: CVE-2019-1003042 is a medium-severity cross-site scripting vulnerability in Jenkins Lockable Resources Plugin, published on 28 Mar 2019. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-1003042 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.6wind.jenkins:lockable-resources (Maven): affected all versions; fixed in 2.5
- org.6wind.jenkins:lockable-resources (Maven): affected all versions; fixed in 2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003042/ (Markdown: https://insights.sbomify.com/CVE-2019-1003042/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003042
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003042
- OSV: https://osv.dev/vulnerability/CVE-2019-1003042

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003042/
Summaries are generated and may contain mistakes; the official description above is the record.
