# CVE-2019-1003045: ECS Publisher Plugin stored and displayed API token in plain text

> Attackers with specific permissions or local access can obtain the plugin's API token, leading to credential exposure and potential security bypass.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-ffj8-w4rj-vr7v

## What is CVE-2019-1003045?

CVE-2019-1003045 is a medium-severity vulnerability in Jenkins ECS Publisher Plugin, published on 28 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability in Jenkins ECS Publisher Plugin 1.0.0 and earlier allows attackers with Item/Extended Read permission, or local file system access to the Jenkins home directory to obtain the API token configured in this plugin's configuration.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2019-1003045?

2 open source packages ship an affected version, including de.eacg:ecs-publisher. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `de.eacg:ecs-publisher` | Maven | All versions | 1.0.1 |
| `de.eacg:ecs-publisher` | Maven | All versions | 1.0.1 |

Products: Trustsource Ecs Publisher.

## How do I fix CVE-2019-1003045?

Upgrade de.eacg:ecs-publisher to 1.0.1 or later.

## Is CVE-2019-1003045 being exploited?

There is no known exploitation of CVE-2019-1003045 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003045 and fix it if it is affected.

What it is: CVE-2019-1003045 is a medium-severity vulnerability in Jenkins ECS Publisher Plugin, published on 28 Mar 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003045 in the wild and no public exploit code.

Affected packages and fixed versions:
- de.eacg:ecs-publisher (Maven): affected all versions; fixed in 1.0.1
- de.eacg:ecs-publisher (Maven): affected all versions; fixed in 1.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003045/ (Markdown: https://insights.sbomify.com/CVE-2019-1003045/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003045
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003045
- OSV: https://osv.dev/vulnerability/CVE-2019-1003045

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003045/
Summaries are generated and may contain mistakes; the official description above is the record.
