# CVE-2019-1003046: Jenkins Fortify on Demand Uploader Plugin CSRF vulnerability

> Attackers can exploit CSRF in the Jenkins Fortify on Demand Uploader Plugin to force connections to malicious servers.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Mar 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-7jcx-j6gv-m4hf

## What is CVE-2019-1003046?

CVE-2019-1003046 is a medium-severity vulnerability in Jenkins Fortify on Demand Uploader Plugin, published on 28 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery vulnerability in Jenkins Fortify on Demand Uploader Plugin 3.0.10 and earlier allows attackers to initiate a connection to an attacker-specified server.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-1003046?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:fortify-on-demand-uploader. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:fortify-on-demand-uploader` | Maven | All versions | 3.0.11 |
| `org.jenkins-ci.plugins:fortify-on-demand-uploader` | Maven | All versions | 3.0.11 |

Products: Jenkins Fortify on Demand Uploader.

## How do I fix CVE-2019-1003046?

Upgrade org.jenkins-ci.plugins:fortify-on-demand-uploader to 3.0.11 or later.

## Is CVE-2019-1003046 being exploited?

There is no known exploitation of CVE-2019-1003046 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Fortify on Demand Uploader Plugin

- [CVE-2019-1003047](https://insights.sbomify.com/CVE-2019-1003047/): SSRF vulnerability due to missing permission check in Fortify on Demand Uploader Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003046 and fix it if it is affected.

What it is: CVE-2019-1003046 is a medium-severity vulnerability in Jenkins Fortify on Demand Uploader Plugin, published on 28 Mar 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-1003046 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:fortify-on-demand-uploader (Maven): affected all versions; fixed in 3.0.11
- org.jenkins-ci.plugins:fortify-on-demand-uploader (Maven): affected all versions; fixed in 3.0.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003046/ (Markdown: https://insights.sbomify.com/CVE-2019-1003046/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003046
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003046
- OSV: https://osv.dev/vulnerability/CVE-2019-1003046

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003046/
Summaries are generated and may contain mistakes; the official description above is the record.
