# CVE-2019-1003048: Jenkins PRQA Plugin stored password in plain text

> Attackers with local file system access can obtain unencrypted passwords from the Jenkins PRQA Plugin configuration.

- **Severity:** High 7.8 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Mar 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-mxmw-6qgj-h67x

## What is CVE-2019-1003048?

CVE-2019-1003048 is a high-severity vulnerability in Jenkins PRQA Plugin, published on 28 Mar 2019. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

A vulnerability in Jenkins PRQA Plugin 3.1.0 and earlier allows attackers with local file system access to the Jenkins home directory to obtain the unencrypted password from the plugin configuration.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2019-1003048?

2 open source packages ship an affected version, including com.programmingresearch:prqa-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.programmingresearch:prqa-plugin` | Maven | All versions | 3.1.2 |
| `com.programmingresearch:prqa-plugin` | Maven | All versions | 3.1.2 |

Products: Jenkins Prqa.

## How do I fix CVE-2019-1003048?

Upgrade com.programmingresearch:prqa-plugin to 3.1.2 or later.

## Is CVE-2019-1003048 being exploited?

There is no known exploitation of CVE-2019-1003048 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003048 and fix it if it is affected.

What it is: CVE-2019-1003048 is a high-severity vulnerability in Jenkins PRQA Plugin, published on 28 Mar 2019. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003048 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.programmingresearch:prqa-plugin (Maven): affected all versions; fixed in 3.1.2
- com.programmingresearch:prqa-plugin (Maven): affected all versions; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003048/ (Markdown: https://insights.sbomify.com/CVE-2019-1003048/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003048
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003048
- OSV: https://osv.dev/vulnerability/CVE-2019-1003048

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003048/
Summaries are generated and may contain mistakes; the official description above is the record.
