# CVE-2019-1003071: Jenkins Octopus Deploy Plugin stores credentials in plain text

> Attackers with master file system access can read unencrypted credentials stored by the Jenkins OctopusDeploy Plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-r798-qx7r-v3gw

## What is CVE-2019-1003071?

CVE-2019-1003071 is a high-severity vulnerability in Jenkins OctopusDeploy Plugin, published on 4 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins OctopusDeploy Plugin stores credentials unencrypted in its global configuration file on the Jenkins master where they can be viewed by users with access to the master file system.

Weakness: CWE-311 (Missing Encryption of Sensitive Data)

## Which versions are affected by CVE-2019-1003071?

2 open source packages ship an affected version, including hudson.plugins.octopusdeploy:octopusdeploy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hudson.plugins.octopusdeploy:octopusdeploy` | Maven | All versions | 1.9.0 |
| `hudson.plugins.octopusdeploy:octopusdeploy` | Maven | All versions | 1.9.0 |

Products: Jenkins Octopusdeploy.

## How do I fix CVE-2019-1003071?

Upgrade hudson.plugins.octopusdeploy:octopusdeploy to 1.9.0 or later.

## Is CVE-2019-1003071 being exploited?

There is no known exploitation of CVE-2019-1003071 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins OctopusDeploy Plugin

- [CVE-2019-1003027](https://insights.sbomify.com/CVE-2019-1003027/): SSRF vulnerability due to missing permission check in Jenkins OctopusDeploy Plugin (medium 4.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003071 and fix it if it is affected.

What it is: CVE-2019-1003071 is a high-severity vulnerability in Jenkins OctopusDeploy Plugin, published on 4 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003071 in the wild and no public exploit code.

Affected packages and fixed versions:
- hudson.plugins.octopusdeploy:octopusdeploy (Maven): affected all versions; fixed in 1.9.0
- hudson.plugins.octopusdeploy:octopusdeploy (Maven): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003071/ (Markdown: https://insights.sbomify.com/CVE-2019-1003071/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003071
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003071
- OSV: https://osv.dev/vulnerability/CVE-2019-1003071

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003071/
Summaries are generated and may contain mistakes; the official description above is the record.
