# CVE-2019-1003083: Missing permission check in Jenkins Gearman Plugin

> Attackers with read permissions can bypass authorization checks to initiate connections to arbitrary servers via the Gearman plugin configuration.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 4 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-6pj9-5q6j-j97c

## What is CVE-2019-1003083?

CVE-2019-1003083 is a medium-severity missing authorization vulnerability in Jenkins Gearman Plugin, published on 4 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A missing permission check in Jenkins Gearman Plugin in the GearmanPluginConfig#doTestConnection form validation method allows attackers with Overall/Read permission to initiate a connection to an attacker-specified server.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2019-1003083?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:gearman-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:gearman-plugin` | Maven | All versions | 0.4.0 |
| `org.jenkins-ci.plugins:gearman-plugin` | Maven | All versions | 0.4.0 |

Products: Jenkins Gearman.

## How do I fix CVE-2019-1003083?

Upgrade org.jenkins-ci.plugins:gearman-plugin to 0.4.0 or later.

## Is CVE-2019-1003083 being exploited?

There is no known exploitation of CVE-2019-1003083 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Gearman Plugin

- [CVE-2019-1003082](https://insights.sbomify.com/CVE-2019-1003082/): CSRF vulnerability in Jenkins Gearman Plugin (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003083 and fix it if it is affected.

What it is: CVE-2019-1003083 is a medium-severity missing authorization vulnerability in Jenkins Gearman Plugin, published on 4 Apr 2019. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1003083 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:gearman-plugin (Maven): affected all versions; fixed in 0.4.0
- org.jenkins-ci.plugins:gearman-plugin (Maven): affected all versions; fixed in 0.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003083/ (Markdown: https://insights.sbomify.com/CVE-2019-1003083/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003083
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003083
- OSV: https://osv.dev/vulnerability/CVE-2019-1003083

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003083/
Summaries are generated and may contain mistakes; the official description above is the record.
