# CVE-2019-1003098: Jenkins OpenID Plugin CSRF vulnerability

> Attackers can exploit CSRF in the Jenkins openid Plugin to initiate connections to attacker-controlled servers via form validation.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Apr 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-8v26-3p83-mf2g

## What is CVE-2019-1003098?

CVE-2019-1003098 is a medium-severity vulnerability in Jenkins openid Plugin, published on 4 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A cross-site request forgery vulnerability in Jenkins openid Plugin in the OpenIdSsoSecurityRealm.DescriptorImpl#doValidate form validation method allows attackers to initiate a connection to an attacker-specified server.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2019-1003098?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:openid. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:openid` | Maven | All versions | 2.4 |
| `org.jenkins-ci.plugins:openid` | Maven | All versions | 2.4 |

Products: Jenkins Openid.

## How do I fix CVE-2019-1003098?

Upgrade org.jenkins-ci.plugins:openid to 2.4 or later.

## Is CVE-2019-1003098 being exploited?

There is no known exploitation of CVE-2019-1003098 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins openid Plugin

- [CVE-2023-24444](https://insights.sbomify.com/CVE-2023-24444/): Session fixation vulnerability in Jenkins OpenID Plugin (critical 9.8)
- [CVE-2023-24446](https://insights.sbomify.com/CVE-2023-24446/): Cross-site request forgery vulnerability in Jenkins OpenID Plugin (high 8.8)
- [CVE-2023-50770](https://insights.sbomify.com/CVE-2023-50770/): Password stored in a recoverable format by Jenkins OpenId Connect Authentication Plugin (medium 6.7)
- [CVE-2019-1003099](https://insights.sbomify.com/CVE-2019-1003099/): Jenkins openid Plugin missing permission check (medium 6.5)
- [CVE-2023-24445](https://insights.sbomify.com/CVE-2023-24445/): Open redirect vulnerability in Jenkins OpenID Plugin (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1003098 and fix it if it is affected.

What it is: CVE-2019-1003098 is a medium-severity vulnerability in Jenkins openid Plugin, published on 4 Apr 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-1003098 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:openid (Maven): affected all versions; fixed in 2.4
- org.jenkins-ci.plugins:openid (Maven): affected all versions; fixed in 2.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1003098/ (Markdown: https://insights.sbomify.com/CVE-2019-1003098/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1003098
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1003098
- OSV: https://osv.dev/vulnerability/CVE-2019-1003098

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1003098/
Summaries are generated and may contain mistakes; the official description above is the record.
