{"answers":{"affected":"2 open source packages ship an affected version, including aurelia-framework. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-10062 in the wild and no public exploit code.","fix":"Upgrade aurelia-framework to 1.4.1 or later.","what":"CVE-2019-10062 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-10062 and fix it if it is affected.\n\nWhat it is: CVE-2019-10062 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-10062 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aurelia-framework (npm): affected all versions; fixed in 1.4.1\n- aurelia-framework (npm): affected all versions; fixed in 1.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-10062/ (Markdown: https://insights.sbomify.com/CVE-2019-10062/index.md)","id":"CVE-2019-10062","markdown":"https://insights.sbomify.com/CVE-2019-10062/index.md","name":"CVE-2019-10062","record":{"aliases":["GHSA-m6j2-v3gq-45r5"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Aurelia HTML sanitizer","requires_auth":"none","summary":"Remote attackers can execute arbitrary JavaScript via XSS due to insufficient HTML sanitization in the Aurelia framework.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"aurelia_framework","vendor":"bluespire"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"The HTMLSanitizer class in html-sanitizer.ts in all released versions of the Aurelia framework 1.x repository is vulnerable to XSS. The sanitizer only attempts to filter SCRIPT elements, which makes it feasible for remote attackers to conduct XSS attacks via (for example) JavaScript code in an attribute of various other elements. An attacker might also exploit a bug in how the SCRIPT string is processed by splitting and nesting them for example.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site Scripting in aurelia-framework","id":"CVE-2019-10062","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2019"},"n_packages":2,"n_references":3,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2019-10063"},"packages":[{"ecosystem":"npm","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"aurelia-framework","purl":null,"source":"GHSA-m6j2-v3gq-45r5"},{"ecosystem":"npm","fixed":["1.4.1"],"introduced":["0"],"last_affected":[],"package":"aurelia-framework","purl":"pkg:npm/aurelia-framework","source":"GHSA-m6j2-v3gq-45r5"}],"prev":{"headline":"OS Command Injection in node-opencv","id":"CVE-2019-10061"},"products":["n/a"],"published":"2021-05-13","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary JavaScript via XSS due to insufficient HTML sanitization in the Aurelia framework.","url":"https://insights.sbomify.com/CVE-2019-10062/"}