# CVE-2019-10062: Cross-site Scripting in aurelia-framework

> Remote attackers can execute arbitrary JavaScript via XSS due to insufficient HTML sanitization in the Aurelia framework.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 May 2021
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-m6j2-v3gq-45r5

## What is CVE-2019-10062?

CVE-2019-10062 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

The HTMLSanitizer class in html-sanitizer.ts in all released versions of the Aurelia framework 1.x repository is vulnerable to XSS. The sanitizer only attempts to filter SCRIPT elements, which makes it feasible for remote attackers to conduct XSS attacks via (for example) JavaScript code in an attribute of various other elements. An attacker might also exploit a bug in how the SCRIPT string is processed by splitting and nesting them for example.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2019-10062?

2 open source packages ship an affected version, including aurelia-framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aurelia-framework` | npm | All versions | 1.4.1 |
| `aurelia-framework` | npm | All versions | 1.4.1 |

Products: Bluespire Aurelia Framework.

## How do I fix CVE-2019-10062?

Upgrade aurelia-framework to 1.4.1 or later.

## Is CVE-2019-10062 being exploited?

There is no known exploitation of CVE-2019-10062 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10062 and fix it if it is affected.

What it is: CVE-2019-10062 is a medium-severity cross-site scripting vulnerability in n/a, published on 13 May 2021. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10062 in the wild and no public exploit code.

Affected packages and fixed versions:
- aurelia-framework (npm): affected all versions; fixed in 1.4.1
- aurelia-framework (npm): affected all versions; fixed in 1.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10062/ (Markdown: https://insights.sbomify.com/CVE-2019-10062/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10062
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10062
- OSV: https://osv.dev/vulnerability/CVE-2019-10062

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10062/
Summaries are generated and may contain mistakes; the official description above is the record.
