CVE-2019-10079 Denial of service in Apache Traffic Server

High 7.5 Published Updated

Attackers can cause denial of service in Apache Traffic Server by flooding HTTP/2 setting frames, requiring an upgrade to patched versions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2019-10079?

CVE-2019-10079 is a high-severity denial of service vulnerability in Apache Traffic Server, published on 22 Oct 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Apache Traffic Server is vulnerable to HTTP/2 setting flood attacks. Earlier versions of Apache Traffic Server didn't limit the number of setting frames sent from the client using the HTTP/2 protocol. Users should upgrade to Apache Traffic Server 7.1.7, 8.0.4, or later versions.

Weakness: CWE-770

Which versions are affected by CVE-2019-10079?

It affects 1 product.

Products include Apache Traffic Server.

How do I fix CVE-2019-10079?

Upgrade to a fixed version.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2019-10079 being exploited?

There is no known exploitation of CVE-2019-10079 in the wild and no public exploit code.

All Apache Traffic Server vulnerabilities

Sources

Also known as DEBIAN-CVE-2019-10079, GHSA-gf9c-jvmp-j8cg, UBUNTU-CVE-2019-10079.

Is CVE-2019-10079 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free