CVE-2019-10088 Allocation of Resources Without Limits or Throttling in Apache Tika

High 8.8 Published Updated

Attackers can cause an out-of-memory error in Apache Tika by providing a crafted or corrupt zip file, leading to service disruption.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-10088?

CVE-2019-10088 is a high-severity denial of service vulnerability in Apache Tika, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

A carefully crafted or corrupt zip file can cause an OOM in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Users should upgrade to 1.22 or later.

Weakness: CWE-770

Which versions are affected by CVE-2019-10088?

2 open source packages ship an affected version, including org.apache.tika:tika-core. It affects 1 product.

PackageAffectedFixed in
org.apache.tika:tika-core MavenFrom 1.71.22
org.apache.tika:tika-core MavenFrom 1.71.22

Products include Apache Tika.

How do I fix CVE-2019-10088?

Upgrade org.apache.tika:tika-core to 1.22 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2019-10088 being exploited?

There is no known exploitation of CVE-2019-10088 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2019-10088, GHSA-mfwh-gqx8-c787.

Is CVE-2019-10088 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free