# CVE-2019-10091: Apache Geode SSL endpoint verification vulnerability

> Apache Geode fails to verify certificate hostnames during TLS handshakes, allowing man-in-the-middle attacks on intra-cluster communication.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 16 Mar 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-wc4x-4gm2-74j8

## What is CVE-2019-10091?

CVE-2019-10091 is a high-severity vulnerability in Apache Geode, published on 16 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When TLS is enabled with ssl-endpoint-identification-enabled set to true, Apache Geode fails to perform hostname verification of the entries in the certificate SAN during the SSL handshake. This could compromise intra-cluster communication using a man-in-the-middle attack.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2019-10091?

2 open source packages ship an affected version, including org.apache.geode:geode-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.geode:geode-core` | Maven | All versions | 1.10.0 |
| `org.apache.geode:geode-core` | Maven | All versions | 1.10.0 |

Products: Apache Geode.

## How do I fix CVE-2019-10091?

Upgrade org.apache.geode:geode-core to 1.10.0 or later.

## Is CVE-2019-10091 being exploited?

There is no known exploitation of CVE-2019-10091 in the wild and no public exploit code.

## Other vulnerabilities in Apache Geode

- [CVE-2020-1938](https://insights.sbomify.com/CVE-2020-1938/): Apache Tomcat Improper Privilege Management (critical 9.8, exploited in the wild)
- [CVE-2019-15752](https://insights.sbomify.com/CVE-2019-15752/): Docker Desktop Community Edition Privilege Escalation (high 7.8, exploited in the wild)
- [CVE-2022-37021](https://insights.sbomify.com/CVE-2022-37021/): Apache Geode deserialization of untrusted data flaw when using JMX over RMI on Java 8. (critical 9.8)
- [CVE-2014-0048](https://insights.sbomify.com/CVE-2014-0048/): Supply chain in docker.io (critical 9.8)
- [CVE-2017-15692](https://insights.sbomify.com/CVE-2017-15692/): Apache Geode unsafe deserialization in TcpServer (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10091 and fix it if it is affected.

What it is: CVE-2019-10091 is a high-severity vulnerability in Apache Geode, published on 16 Mar 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10091 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.geode:geode-core (Maven): affected all versions; fixed in 1.10.0
- org.apache.geode:geode-core (Maven): affected all versions; fixed in 1.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10091/ (Markdown: https://insights.sbomify.com/CVE-2019-10091/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10091
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10091
- OSV: https://osv.dev/vulnerability/CVE-2019-10091

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10091/
Summaries are generated and may contain mistakes; the official description above is the record.
