# CVE-2019-10093: Allocation of Resources Without Limits or Throttling in Apache Tika

> Attackers can cause application hangs by submitting crafted files that exhaust SAXParser pools in Apache Tika.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 2 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-10093, GHSA-4mq5-mj59-qq9c

## What is CVE-2019-10093?

CVE-2019-10093 is a medium-severity denial of service vulnerability in Apache Tika, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Apache Tika 1.19 to 1.21, a carefully crafted 2003ml or 2006ml file could consume all available SAXParsers in the pool and lead to very long hangs. Apache Tika users should upgrade to 1.22 or later.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2019-10093?

2 open source packages ship an affected version, including org.apache.tika:tika-parsers. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.tika:tika-parsers` | Maven | From 1.19 | 1.22 |
| `org.apache.tika:tika-parsers` | Maven | From 1.19 | 1.22 |

Products: Apache Tika.

## How do I fix CVE-2019-10093?

Upgrade org.apache.tika:tika-parsers to 1.22 or later.

## Is CVE-2019-10093 being exploited?

There is no known exploitation of CVE-2019-10093 in the wild and no public exploit code.

## Other vulnerabilities in Apache Tika

- [CVE-2019-10088](https://insights.sbomify.com/CVE-2019-10088/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 8.8)
- [CVE-2025-66516](https://insights.sbomify.com/CVE-2025-66516/): Apache Tika has XXE vulnerability (high 8.4)
- [CVE-2025-54988](https://insights.sbomify.com/CVE-2025-54988/): Apache Tika PDF parser module: XXE vulnerability in PDFParser's handling of XFA (high 8.4)
- [CVE-2018-1335](https://insights.sbomify.com/CVE-2018-1335/): Command injection in org.apache.tika:tika-core (high 8.1)
- [CVE-2019-10094](https://insights.sbomify.com/CVE-2019-10094/): Allocation of Resources Without Limits or Throttling in Apache Tika (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10093 and fix it if it is affected.

What it is: CVE-2019-10093 is a medium-severity denial of service vulnerability in Apache Tika, published on 2 Aug 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-10093 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.tika:tika-parsers (Maven): affected from 1.19; fixed in 1.22
- org.apache.tika:tika-parsers (Maven): affected from 1.19; fixed in 1.22

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10093/ (Markdown: https://insights.sbomify.com/CVE-2019-10093/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10093
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10093
- OSV: https://osv.dev/vulnerability/CVE-2019-10093

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10093/
Summaries are generated and may contain mistakes; the official description above is the record.
