CVE-2019-10094 Allocation of Resources Without Limits or Throttling in Apache Tika

High 7.8 Published Updated

A crafted recursive archive causes a StackOverflowError in Apache Tika, leading to denial of service for applications processing untrusted files.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-10094?

CVE-2019-10094 is a high-severity denial of service vulnerability in Apache Tika, published on 2 Aug 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

Official description

A carefully crafted package/compressed file that, when unzipped/uncompressed yields the same file (a quine), causes a StackOverflowError in Apache Tika's RecursiveParserWrapper in versions 1.7-1.21. Apache Tika users should upgrade to 1.22 or later.

Weakness: CWE-770

Which versions are affected by CVE-2019-10094?

2 open source packages ship an affected version, including org.apache.tika:tika-core. It affects 1 product.

PackageAffectedFixed in
org.apache.tika:tika-core MavenFrom 1.71.22
org.apache.tika:tika-core MavenFrom 1.71.22

Products include Apache Tika.

How do I fix CVE-2019-10094?

Upgrade org.apache.tika:tika-core to 1.22 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2019-10094 being exploited?

There is no known exploitation of CVE-2019-10094 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2019-10094, GHSA-mm7m-xg4h-6m52.

Is CVE-2019-10094 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free