# CVE-2019-10099: Sensitive data written to disk unencrypted in Spark

> Apache Spark fails to encrypt user data written to local disk in specific scenarios, potentially exposing sensitive information to local attackers.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Aug 2019
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-fp5j-3fpf-mhj5, PYSEC-2019-114

## What is CVE-2019-10099?

CVE-2019-10099 is a high-severity vulnerability in Apache Spark, published on 7 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Prior to Spark 2.3.3, in certain situations Spark would write user data to local disk unencrypted, even if spark.io.encryption.enabled=true. This includes cached blocks that are fetched to disk (controlled by spark.maxRemoteBlockSizeFetchToMem); in SparkR, using parallelize; in Pyspark, using broadcast and parallelize; and use of python udfs.

Weakness: CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2019-10099?

5 open source packages ship an affected version, including org.apache.spark:spark-core_2.11 and pyspark. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.spark:spark-core_2.11` | Maven | All versions | 2.3.3 |
| `org.apache.spark:spark-core_2.11` | Maven | All versions | 2.3.3 |
| `pyspark` | PyPI | All versions | 2.3.3 |
| `pyspark` | PyPI | All versions | 2.3.3 |
| `pyspark` | PyPI | All versions | 2.3.3 |

Products: Apache Spark.

## How do I fix CVE-2019-10099?

Upgrade org.apache.spark:spark-core_2.11 to 2.3.3 or later.

## Is CVE-2019-10099 being exploited?

There is no known exploitation of CVE-2019-10099 in the wild and no public exploit code.

## Other vulnerabilities in Apache Spark

- [CVE-2022-33891](https://insights.sbomify.com/CVE-2022-33891/): Apache Spark Command Injection (high 8.8, exploited in the wild)
- [CVE-2020-9480](https://insights.sbomify.com/CVE-2020-9480/): Improper Authentication in Apache Spark (critical 9.8)
- [CVE-2018-17190](https://insights.sbomify.com/CVE-2018-17190/): Remote Code Execution in spark-core (critical 9.8)
- [CVE-2019-20445](https://insights.sbomify.com/CVE-2019-20445/): HTTP Request Smuggling in Netty (critical 9.1)
- [CVE-2025-54920](https://insights.sbomify.com/CVE-2025-54920/): Apache Spark: Spark History Server Code Execution Vulnerability (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-10099 and fix it if it is affected.

What it is: CVE-2019-10099 is a high-severity vulnerability in Apache Spark, published on 7 Aug 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-10099 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.spark:spark-core_2.11 (Maven): affected all versions; fixed in 2.3.3
- org.apache.spark:spark-core_2.11 (Maven): affected all versions; fixed in 2.3.3
- pyspark (PyPI): affected all versions; fixed in 2.3.3
- pyspark (PyPI): affected all versions; fixed in 2.3.3
- pyspark (PyPI): affected all versions; fixed in 2.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-10099/ (Markdown: https://insights.sbomify.com/CVE-2019-10099/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-10099
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-10099
- OSV: https://osv.dev/vulnerability/CVE-2019-10099

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-10099/
Summaries are generated and may contain mistakes; the official description above is the record.
