CVE-2019-1010018 Cross-site scripting in Zammad
An attacker can execute arbitrary JavaScript in a victim's browser by tricking them into opening a malicious ticket in Zammad.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2019-1010018?
CVE-2019-1010018 is a medium-severity cross-site scripting vulnerability in Zammad Zammad, published on 16 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Zammad GmbH Zammad 2.3.0 and earlier is affected by: Cross Site Scripting (XSS) - CWE-80. The impact is: Execute java script code on users browser. The component is: web app. The attack vector is: the victim must open a ticket. The fixed version is: 2.3.1, 2.2.2 and 2.1.3.
Which versions are affected by CVE-2019-1010018?
It affects 1 product.
Products include Zammad Zammad.
How do I fix CVE-2019-1010018?
No fix has been published for CVE-2019-1010018 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2019-1010018 being exploited?
There is no known exploitation of CVE-2019-1010018 in the wild and no public exploit code.
Other vulnerabilities in Zammad Zammad
Sources
Also known as GHSA-qhqc-h6cg-hx9p.