CVE-2019-1010083 Pallets Project Flask is vulnerable to Denial of Service via Unexpected memory usage
Attackers can cause denial of service in Flask applications by sending crafted encoded JSON data, leading to unexpected memory usage.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-1010083?
CVE-2019-1010083 is a high-severity denial of service vulnerability in The Pallets Project Flask, published on 17 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Pallets Project Flask before 1.0 is affected by: unexpected memory usage. The impact is: denial of service. The attack vector is: crafted encoded JSON data. The fixed version is: 1. NOTE: this may overlap CVE-2018-1000656.
Which versions are affected by CVE-2019-1010083?
3 open source packages ship an affected version, including flask and Flask. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
flask PyPI | All versions | 1.0 |
flask PyPI | All versions | 1.0 |
Flask PyPI | All versions | 1.0 |
Linux distribution packages (1)
python-Flask SUSE:Linux Enterprise Module for Public Cloud 12 | All versions | 0.12.1-7.7.1 |
Products include Palletsprojects Flask.
How do I fix CVE-2019-1010083?
Upgrade flask to 1.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2019-1010083 being exploited?
There is no known exploitation of CVE-2019-1010083 in the wild and no public exploit code.
Other vulnerabilities in The Pallets Project Flask
Sources
Also known as CLSA-2026-1772323849, DEBIAN-CVE-2019-1010083, GHSA-5wv5-4vpf-pj6m, PYSEC-2019-179, SUSE-SU-2023:1928-1.