{"answers":{"affected":"3 open source packages ship an affected version, including flask and Flask. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1010083 in the wild and no public exploit code.","fix":"Upgrade flask to 1.0 or later.","what":"CVE-2019-1010083 is a high-severity denial of service vulnerability in The Pallets Project Flask, published on 17 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1010083 and fix it if it is affected.\n\nWhat it is: CVE-2019-1010083 is a high-severity denial of service vulnerability in The Pallets Project Flask, published on 17 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-1010083 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flask (PyPI): affected all versions; fixed in 1.0\n- flask (PyPI): affected all versions; fixed in 1.0\n- Flask (PyPI): affected all versions; fixed in 1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1010083/ (Markdown: https://insights.sbomify.com/CVE-2019-1010083/index.md)","id":"CVE-2019-1010083","markdown":"https://insights.sbomify.com/CVE-2019-1010083/index.md","name":"CVE-2019-1010083","record":{"aliases":["CLSA-2026-1772323849","DEBIAN-CVE-2019-1010083","GHSA-5wv5-4vpf-pj6m","PYSEC-2019-179","SUSE-SU-2023:1928-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python web framework","requires_auth":"none","summary":"Attackers can cause denial of service in Flask applications by sending crafted encoded JSON data, leading to unexpected memory usage.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dwf","cpe":[{"product":"flask","vendor":"palletsprojects"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[],"description":"The Pallets Project Flask before 1.0 is affected by: unexpected memory usage. The impact is: denial of service. The attack vector is: crafted encoded JSON data. The fixed version is: 1. NOTE: this may overlap CVE-2018-1000656.","ecosystems":["PyPI","SUSE:Linux Enterprise Module for Public Cloud 12"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pallets Project Flask is vulnerable to Denial of Service via Unexpected memory usage","id":"CVE-2019-1010083","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":4,"n_references":1,"next":{"headline":"Missing authorization in Dancer::Plugin::SimpleCRUD","id":"CVE-2019-1010084"},"packages":[{"ecosystem":"PyPI","fixed":["1.0"],"introduced":["0"],"last_affected":[],"package":"Flask","purl":null,"source":"GHSA-5wv5-4vpf-pj6m"},{"ecosystem":"PyPI","fixed":["1.0"],"introduced":["0"],"last_affected":[],"package":"flask","purl":"pkg:pypi/flask","source":"GHSA-5wv5-4vpf-pj6m"},{"ecosystem":"PyPI","fixed":["1.0"],"introduced":["0"],"last_affected":[],"package":"flask","purl":"pkg:pypi/flask","source":"PYSEC-2019-179"},{"ecosystem":"SUSE:Linux Enterprise Module for Public Cloud 12","fixed":["0.12.1-7.7.1"],"introduced":["0"],"last_affected":[],"package":"python-Flask","purl":"pkg:rpm/suse/python-Flask\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Public%20Cloud%2012","source":"SUSE-SU-2023:1928-1"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2019-1010073"},"products":["Flask"],"published":"2019-07-17","related":[{"cvss_score":7.5,"headline":"Flask vulnerable to possible disclosure of permanent session cookie due to missing Vary: Cookie header","id":"CVE-2023-30861","kev_date_added":null,"published":"2023-05-02"},{"cvss_score":2.3,"headline":"Flask session does not add `Vary: Cookie` header when accessed in some ways","id":"CVE-2026-27205","kev_date_added":null,"published":"2026-02-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["The Pallets Project"]},"summary":"Attackers can cause denial of service in Flask applications by sending crafted encoded JSON data, leading to unexpected memory usage.","url":"https://insights.sbomify.com/CVE-2019-1010083/"}