CVE-2019-1010142 Infinite Loop in scapy
Attackers can cause a denial of service via infinite loop in Scapy's RADIUS packet parsing, affecting applications processing malicious network traffic or pcap files.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2019-1010142?
CVE-2019-1010142 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
scapy 2.4.0 is affected by: Denial of Service. The impact is: infinite loop, resource consumption and program unresponsive. The component is: _RADIUSAttrPacketListField.getfield(self..). The attack vector is: over the network or in a pcap. both work.
Weakness: CWE-835
Which versions are affected by CVE-2019-1010142?
3 open source packages ship an affected version, including scapy. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
scapy PyPI | All versions | 2.4.1 |
scapy PyPI | From 2.4-rc1 | 2.4.1 |
scapy PyPI | From 2.4-rc1 | 2.4.1 |
Products include Fedoraproject Fedora, Scapy Scapy.
How do I fix CVE-2019-1010142?
Upgrade scapy to 2.4.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2019-1010142 being exploited?
There is no known exploitation of CVE-2019-1010142 in the wild and no public exploit code.
Other vulnerabilities in Fedoraproject Fedora
Sources
Also known as CVE-2019-1010262, DEBIAN-CVE-2019-1010142, GHSA-mpf2-q34c-fc6j, PYSEC-2019-120.