{"answers":{"affected":"3 open source packages ship an affected version, including scapy. It affects 2 products.","exploited":"There is no known exploitation of CVE-2019-1010142 in the wild and no public exploit code.","fix":"Upgrade scapy to 2.4.1 or later.","what":"CVE-2019-1010142 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1010142 and fix it if it is affected.\n\nWhat it is: CVE-2019-1010142 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-1010142 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- scapy (PyPI): affected all versions; fixed in 2.4.1\n- scapy (PyPI): affected from 2.4-rc1; fixed in 2.4.1\n- scapy (PyPI): affected from 2.4-rc1; fixed in 2.4.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1010142/ (Markdown: https://insights.sbomify.com/CVE-2019-1010142/index.md)","id":"CVE-2019-1010142","markdown":"https://insights.sbomify.com/CVE-2019-1010142/index.md","name":"CVE-2019-1010142","record":{"aliases":["CVE-2019-1010262","DEBIAN-CVE-2019-1010142","GHSA-mpf2-q34c-fc6j","PYSEC-2019-120"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python network library","requires_auth":"none","summary":"Attackers can cause a denial of service via infinite loop in Scapy's RADIUS packet parsing, affecting applications processing malicious network traffic or pcap files.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dwf","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"scapy","vendor":"scapy"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-835","name":"Loop with Unreachable Exit Condition"}],"description":"scapy 2.4.0 is affected by: Denial of Service. The impact is: infinite loop, resource consumption and program unresponsive. The component is: _RADIUSAttrPacketListField.getfield(self..). The attack vector is: over the network or in a pcap. both work.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Infinite Loop in scapy","id":"CVE-2019-1010142","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"denial_of_service","year":"2019"},"n_packages":3,"n_references":6,"next":{"headline":"Cross-site scripting in Smart Reporting","id":"CVE-2019-1010147"},"packages":[{"ecosystem":"PyPI","fixed":["2.4.1"],"introduced":["0"],"last_affected":[],"package":"scapy","purl":"pkg:pypi/scapy","source":"PYSEC-2019-120"},{"ecosystem":"PyPI","fixed":["2.4.1"],"introduced":["2.4-rc1"],"last_affected":[],"package":"scapy","purl":null,"source":"GHSA-mpf2-q34c-fc6j"},{"ecosystem":"PyPI","fixed":["2.4.1"],"introduced":["2.4-rc1"],"last_affected":[],"package":"scapy","purl":"pkg:pypi/scapy","source":"GHSA-mpf2-q34c-fc6j"}],"prev":{"headline":"Missing authorization in GPN2.4P21-C-CN","id":"CVE-2019-1010136"},"products":["scapy"],"published":"2019-07-19","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["SecDev"]},"summary":"Attackers can cause a denial of service via infinite loop in Scapy's RADIUS packet parsing, affecting applications processing malicious network traffic or pcap files.","url":"https://insights.sbomify.com/CVE-2019-1010142/"}