# CVE-2019-1010142: Infinite Loop in scapy

> Attackers can cause a denial of service via infinite loop in Scapy's RADIUS packet parsing, affecting applications processing malicious network traffic or pcap files.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 19 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** CVE-2019-1010262, DEBIAN-CVE-2019-1010142, GHSA-mpf2-q34c-fc6j, PYSEC-2019-120

## What is CVE-2019-1010142?

CVE-2019-1010142 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

scapy 2.4.0 is affected by: Denial of Service. The impact is: infinite loop, resource consumption and program unresponsive. The component is: _RADIUSAttrPacketListField.getfield(self..). The attack vector is: over the network or in a pcap. both work.

Weakness: CWE-835 (Loop with Unreachable Exit Condition)

## Which versions are affected by CVE-2019-1010142?

3 open source packages ship an affected version, including scapy. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `scapy` | PyPI | All versions | 2.4.1 |
| `scapy` | PyPI | From 2.4-rc1 | 2.4.1 |
| `scapy` | PyPI | From 2.4-rc1 | 2.4.1 |

Products: Fedoraproject Fedora, Scapy Scapy.

## How do I fix CVE-2019-1010142?

Upgrade scapy to 2.4.1 or later.

## Is CVE-2019-1010142 being exploited?

There is no known exploitation of CVE-2019-1010142 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010142 and fix it if it is affected.

What it is: CVE-2019-1010142 is a high-severity denial of service vulnerability in Fedoraproject Fedora, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1010142 in the wild and no public exploit code.

Affected packages and fixed versions:
- scapy (PyPI): affected all versions; fixed in 2.4.1
- scapy (PyPI): affected from 2.4-rc1; fixed in 2.4.1
- scapy (PyPI): affected from 2.4-rc1; fixed in 2.4.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010142/ (Markdown: https://insights.sbomify.com/CVE-2019-1010142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010142
- OSV: https://osv.dev/vulnerability/CVE-2019-1010142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010142/
Summaries are generated and may contain mistakes; the official description above is the record.
