CVE-2019-1010161 perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control.

Critical 9.8 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2019-1010161?

CVE-2019-1010161 is a critical vulnerability in perl-CRYPT-JWT, published on 25 Jul 2019.

Official description

perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control. The impact is: bypass authentication. The component is: JWT.pm for JWT security token, line 614 in _decode_jws(). The attack vector is: network connectivity(crafting user-controlled input to bypass authentication). The fixed version is: 0.023.

Weakness: CWE-347

Which versions are affected by CVE-2019-1010161?

It affects 1 product.

Products include Perl-Crypt-Jwt Project Perl-Crypt-Jwt.

How do I fix CVE-2019-1010161?

No fix has been published for CVE-2019-1010161 yet. Limit exposure of the affected software until one is available.

Is CVE-2019-1010161 being exploited?

There is no known exploitation of CVE-2019-1010161 in the wild and no public exploit code.

Sources

Also known as GHSA-75ff-mxv3-9xhw.

Is CVE-2019-1010161 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free