# CVE-2019-1010161: perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control.


- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 25 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-75ff-mxv3-9xhw

## What is CVE-2019-1010161?

CVE-2019-1010161 is a critical vulnerability in perl-CRYPT-JWT, published on 25 Jul 2019. 

### Official description

perl-CRYPT-JWT 0.022 and earlier is affected by: Incorrect Access Control. The impact is: bypass authentication. The component is: JWT.pm for JWT security token, line 614 in _decode_jws(). The attack vector is: network connectivity(crafting user-controlled input to bypass authentication). The fixed version is: 0.023.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2019-1010161?

It affects 1 product.


Products: Perl-Crypt-Jwt Project Perl-Crypt-Jwt.

## How do I fix CVE-2019-1010161?

No fix has been published for CVE-2019-1010161 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-1010161 being exploited?

There is no known exploitation of CVE-2019-1010161 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010161 and fix it if it is affected.

What it is: CVE-2019-1010161 is a critical vulnerability in perl-CRYPT-JWT, published on 25 Jul 2019. 
Exploitation: There is no known exploitation of CVE-2019-1010161 in the wild and no public exploit code.

Affected product: perl-CRYPT-JWT. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010161/ (Markdown: https://insights.sbomify.com/CVE-2019-1010161/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010161
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010161
- OSV: https://osv.dev/vulnerability/CVE-2019-1010161

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010161/
Summaries are generated and may contain mistakes; the official description above is the record.
