# CVE-2019-1010174: Command injection in The CImg Library

> Attackers can execute arbitrary commands by providing a malicious URL to the image loading function in the CImg library.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-1010174, GHSA-rp8q-pmmm-p726, UBUNTU-CVE-2019-1010174

## What is CVE-2019-1010174?

CVE-2019-1010174 is a critical command injection vulnerability in Debian Debian Linux, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CImg The CImg Library v.2.3.3 and earlier is affected by: command injection. The impact is: RCE. The component is: load_network() function. The attack vector is: Loading an image from a user-controllable url can lead to command injection, because no string sanitization is done on the url. The fixed version is: v.2.3.4.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2019-1010174?

It affects 2 products.


Products: Cimg Cimg Library, Debian Debian Linux.

## How do I fix CVE-2019-1010174?

Upgrade to a fixed version.

## Is CVE-2019-1010174 being exploited?

There is no known exploitation of CVE-2019-1010174 in the wild and no public exploit code.

Public exploit code:

-  CImg Library v.2.3.3 - command injection (github_poc): https://github.com/NketiahGodfred/CVE-2019-1010174

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010174 and fix it if it is affected.

What it is: CVE-2019-1010174 is a critical command injection vulnerability in Debian Debian Linux, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1010174 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010174/ (Markdown: https://insights.sbomify.com/CVE-2019-1010174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010174
- OSV: https://osv.dev/vulnerability/CVE-2019-1010174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010174/
Summaries are generated and may contain mistakes; the official description above is the record.
