CVE-2019-1010182 Denial of service in yaml-rust

Medium 6.5 Published Updated

Attackers can cause a denial of service via uncontrolled recursion when parsing malicious YAML documents in the yaml-rust library.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2019-1010182?

CVE-2019-1010182 is a medium-severity denial of service vulnerability in yaml-rust, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

yaml-rust 0.4.0 and earlier is affected by: Uncontrolled Recursion. The impact is: Denial of service by impossible to catch abort. The component is: YamlLoader::load_from_str function. The attack vector is: Parsing of a malicious YAML document. The fixed version is: 0.4.1 and later.

Weakness: CWE-674

Which versions are affected by CVE-2019-1010182?

It affects 1 product.

Products include Yaml-Rust Project Yaml-Rust.

How do I fix CVE-2019-1010182?

No fix has been published for CVE-2019-1010182 yet. Limit exposure of the affected software until one is available.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2019-1010182 being exploited?

There is no known exploitation of CVE-2019-1010182 in the wild and no public exploit code.

Sources

Also known as GHSA-78qj-jpww-m9rm.

Is CVE-2019-1010182 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free