{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1010182 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2019-1010182 yet. Limit exposure of the affected software until one is available.","what":"CVE-2019-1010182 is a medium-severity denial of service vulnerability in yaml-rust, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-1010182 and fix it if it is affected.\n\nWhat it is: CVE-2019-1010182 is a medium-severity denial of service vulnerability in yaml-rust, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-1010182 in the wild and no public exploit code.\n\nAffected product: yaml-rust. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1010182/ (Markdown: https://insights.sbomify.com/CVE-2019-1010182/index.md)","id":"CVE-2019-1010182","markdown":"https://insights.sbomify.com/CVE-2019-1010182/index.md","name":"CVE-2019-1010182","record":{"aliases":["GHSA-78qj-jpww-m9rm"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust YAML parser","requires_auth":"none","summary":"Attackers can cause a denial of service via uncontrolled recursion when parsing malicious YAML documents in the yaml-rust library.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dwf","cpe":[{"product":"yaml-rust","vendor":"yaml-rust_project"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"yaml-rust 0.4.0 and earlier is affected by: Uncontrolled Recursion. The impact is: Denial of service by impossible to catch abort. The component is: YamlLoader::load_from_str function. The attack vector is: Parsing of a malicious YAML document. The fixed version is: 0.4.1 and later.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Denial of service in yaml-rust","id":"CVE-2019-1010182","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":0,"n_references":1,"next":{"headline":"Denial of service in serde yaml","id":"CVE-2019-1010183"},"packages":[],"prev":{"headline":"Memory corruption in gdb","id":"CVE-2019-1010180"},"products":["yaml-rust"],"published":"2019-07-25","related":[{"cvss_score":7.5,"headline":"Uncontrolled recursion in rust-yaml","id":"CVE-2018-20993","kev_date_added":null,"published":"2019-08-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["yaml-rust"]},"summary":"Attackers can cause a denial of service via uncontrolled recursion when parsing malicious YAML documents in the yaml-rust library.","url":"https://insights.sbomify.com/CVE-2019-1010182/"}