# CVE-2019-1010182: Denial of service in yaml-rust

> Attackers can cause a denial of service via uncontrolled recursion when parsing malicious YAML documents in the yaml-rust library.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-78qj-jpww-m9rm

## What is CVE-2019-1010182?

CVE-2019-1010182 is a medium-severity denial of service vulnerability in yaml-rust, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

yaml-rust 0.4.0 and earlier is affected by: Uncontrolled Recursion. The impact is: Denial of service by impossible to catch abort. The component is: YamlLoader::load_from_str function. The attack vector is: Parsing of a malicious YAML document. The fixed version is: 0.4.1 and later.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2019-1010182?

It affects 1 product.


Products: Yaml-Rust Project Yaml-Rust.

## How do I fix CVE-2019-1010182?

No fix has been published for CVE-2019-1010182 yet. Limit exposure of the affected software until one is available.

## Is CVE-2019-1010182 being exploited?

There is no known exploitation of CVE-2019-1010182 in the wild and no public exploit code.

## Other vulnerabilities in yaml-rust

- [CVE-2018-20993](https://insights.sbomify.com/CVE-2018-20993/): Uncontrolled recursion in rust-yaml (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010182 and fix it if it is affected.

What it is: CVE-2019-1010182 is a medium-severity denial of service vulnerability in yaml-rust, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-1010182 in the wild and no public exploit code.

Affected product: yaml-rust. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010182/ (Markdown: https://insights.sbomify.com/CVE-2019-1010182/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010182
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010182
- OSV: https://osv.dev/vulnerability/CVE-2019-1010182

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010182/
Summaries are generated and may contain mistakes; the official description above is the record.
