CVE-2019-1010183 Denial of service in serde yaml
Attackers can cause a denial of service by providing a malicious YAML file to applications using the serde_yaml library.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2019-1010183?
CVE-2019-1010183 is a medium-severity denial of service vulnerability in serde_yaml, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
serde serde_yaml 0.6.0 to 0.8.3 is affected by: Uncontrolled Recursion. The impact is: Denial of service by aborting. The component is: from_* functions (all deserialization functions). The attack vector is: Parsing a malicious YAML file. The fixed version is: 0.8.4 and later.
Weakness: CWE-674
Which versions are affected by CVE-2019-1010183?
It affects 1 product.
Products include Serde-Yaml Project Serde-Yaml.
How do I fix CVE-2019-1010183?
No fix has been published for CVE-2019-1010183 yet. Limit exposure of the affected software until one is available.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2019-1010183 being exploited?
There is no known exploitation of CVE-2019-1010183 in the wild and no public exploit code.
Sources
Also known as GHSA-6p2w-7q97-f8hf.