{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1010183 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2019-1010183 yet. Limit exposure of the affected software until one is available.","what":"CVE-2019-1010183 is a medium-severity denial of service vulnerability in serde_yaml, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-1010183 and fix it if it is affected.\n\nWhat it is: CVE-2019-1010183 is a medium-severity denial of service vulnerability in serde_yaml, published on 25 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-1010183 in the wild and no public exploit code.\n\nAffected product: serde_yaml. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1010183/ (Markdown: https://insights.sbomify.com/CVE-2019-1010183/index.md)","id":"CVE-2019-1010183","markdown":"https://insights.sbomify.com/CVE-2019-1010183/index.md","name":"CVE-2019-1010183","record":{"aliases":["GHSA-6p2w-7q97-f8hf"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust YAML library","requires_auth":"none","summary":"Attackers can cause a denial of service by providing a malicious YAML file to applications using the serde_yaml library.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dwf","cpe":[{"product":"serde-yaml","vendor":"serde-yaml_project"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-674","name":"Uncontrolled Recursion"}],"description":"serde serde_yaml 0.6.0 to 0.8.3 is affected by: Uncontrolled Recursion. The impact is: Denial of service by aborting. The component is: from_* functions (all deserialization functions). The attack vector is: Parsing a malicious YAML file. The fixed version is: 0.8.4 and later.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Denial of service in serde yaml","id":"CVE-2019-1010183","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2019"},"n_packages":0,"n_references":1,"next":{"headline":"Denial of service in mgetty","id":"CVE-2019-1010189"},"packages":[],"prev":{"headline":"Denial of service in yaml-rust","id":"CVE-2019-1010182"},"products":["serde_yaml"],"published":"2019-07-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["serde"]},"summary":"Attackers can cause a denial of service by providing a malicious YAML file to applications using the serde_yaml library.","url":"https://insights.sbomify.com/CVE-2019-1010183/"}