CVE-2019-1010190 Denial of service in mgetty
An out-of-bounds read in mgetty allows local attackers to cause a denial of service by tricking a user into opening a specially crafted file.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2019-1010190?
CVE-2019-1010190 is a medium-severity denial of service vulnerability in mgetty, published on 24 Jul 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
mgetty prior to 1.2.1 is affected by: out-of-bounds read. The impact is: DoS, the program may crash if the memory is not mapped. The component is: putwhitespan() in g3/pbm2g3.c. The attack vector is: Local, the victim must open a specially crafted file. The fixed version is: 1.2.1.
Weakness: CWE-125
Which versions are affected by CVE-2019-1010190?
It affects 1 product.
Linux distribution packages (6)
mgetty SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 1.1.37-3.8.1 |
mgetty SUSE:Linux Enterprise Server 12 SP4 | All versions | 1.1.36-58.9.2 |
mgetty SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.1.36-58.9.2 |
mgetty SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 1.1.36-58.9.2 |
mgetty SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.1.36-58.9.2 |
mgetty openSUSE:Leap 15.1 | All versions | 1.1.37-lp151.4.3.1 |
Products include Mgetty Project Mgetty.
How do I fix CVE-2019-1010190?
Upgrade to a fixed version.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2019-1010190 being exploited?
There is no known exploitation of CVE-2019-1010190 in the wild and no public exploit code.
Other vulnerabilities in mgetty
Sources
Also known as DEBIAN-CVE-2019-1010190, GHSA-fqmm-33mv-f756, SUSE-SU-2020:0853-1, SUSE-SU-2020:0957-1, UBUNTU-CVE-2019-1010190, openSUSE-SU-2020:0506-1.