# CVE-2019-1010190: Denial of service in mgetty

> An out-of-bounds read in mgetty allows local attackers to cause a denial of service by tricking a user into opening a specially crafted file.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 24 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2019-1010190, GHSA-fqmm-33mv-f756, SUSE-SU-2020:0853-1, SUSE-SU-2020:0957-1, UBUNTU-CVE-2019-1010190, openSUSE-SU-2020:0506-1

## What is CVE-2019-1010190?

CVE-2019-1010190 is a medium-severity denial of service vulnerability in mgetty, published on 24 Jul 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

mgetty prior to 1.2.1 is affected by: out-of-bounds read. The impact is: DoS, the program may crash if the memory is not mapped. The component is: putwhitespan() in g3/pbm2g3.c. The attack vector is: Local, the victim must open a specially crafted file. The fixed version is: 1.2.1.

Weakness: CWE-125 (Out-of-bounds Read)

## Which versions are affected by CVE-2019-1010190?

It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mgetty` | SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 1.1.37-3.8.1 |
| `mgetty` | SUSE:Linux Enterprise Server 12 SP4 | All versions | 1.1.36-58.9.2 |
| `mgetty` | SUSE:Linux Enterprise Server 12 SP5 | All versions | 1.1.36-58.9.2 |
| `mgetty` | SUSE:Linux Enterprise Server for SAP Applications 12 SP4 | All versions | 1.1.36-58.9.2 |
| `mgetty` | SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 1.1.36-58.9.2 |
| `mgetty` | openSUSE:Leap 15.1 | All versions | 1.1.37-lp151.4.3.1 |

Products: Mgetty Project Mgetty.

## How do I fix CVE-2019-1010190?

Upgrade to a fixed version.

## Is CVE-2019-1010190 being exploited?

There is no known exploitation of CVE-2019-1010190 in the wild and no public exploit code.

## Other vulnerabilities in mgetty

- [CVE-2018-16742](https://insights.sbomify.com/CVE-2018-16742/): Memory corruption in n/a (high 7.8)
- [CVE-2018-16743](https://insights.sbomify.com/CVE-2018-16743/): Memory corruption in n/a (high 7.8)
- [CVE-2018-16744](https://insights.sbomify.com/CVE-2018-16744/): Command injection in n/a (high 7.8)
- [CVE-2018-16745](https://insights.sbomify.com/CVE-2018-16745/): Memory corruption in n/a (high 7.8)
- [CVE-2019-1010189](https://insights.sbomify.com/CVE-2019-1010189/): Denial of service in mgetty (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010190 and fix it if it is affected.

What it is: CVE-2019-1010190 is a medium-severity denial of service vulnerability in mgetty, published on 24 Jul 2019. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2019-1010190 in the wild and no public exploit code.

Affected product: mgetty. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010190/ (Markdown: https://insights.sbomify.com/CVE-2019-1010190/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010190
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010190
- OSV: https://osv.dev/vulnerability/CVE-2019-1010190

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010190/
Summaries are generated and may contain mistakes; the official description above is the record.
