{"answers":{"affected":"2 open source packages ship an affected version, including marginalia. It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1010191 in the wild and no public exploit code.","fix":"Upgrade marginalia to 1.6 or later.","what":"CVE-2019-1010191 is a critical SQL injection vulnerability in marginalia, published on 24 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2019-1010191 and fix it if it is affected.\n\nWhat it is: CVE-2019-1010191 is a critical SQL injection vulnerability in marginalia, published on 24 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2019-1010191 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- marginalia (RubyGems): affected all versions; fixed in 1.6\n- marginalia (RubyGems): affected all versions; fixed in 1.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1010191/ (Markdown: https://insights.sbomify.com/CVE-2019-1010191/index.md)","id":"CVE-2019-1010191","markdown":"https://insights.sbomify.com/CVE-2019-1010191/index.md","name":"CVE-2019-1010191","record":{"aliases":["GHSA-hrj5-qp7x-rpg6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby SQL library","requires_auth":"none","summary":"Attackers can inject arbitrary SQL queries via user-controlled arguments in the marginalia Ruby library, potentially accessing or modifying database contents.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dwf","cpe":[{"product":"marginalia","vendor":"marginalia_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"marginalia \u003c 1.6 is affected by: SQL Injection. The impact is: The impact is a injection of any SQL queries when a user controller argument is added as a component. The component is: Affects users that add a component that is user controller, for instance a parameter or a header. The attack vector is: Hacker inputs a SQL to a vulnerable vector(header, http parameter, etc). The fixed version is: 1.6.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQL Injection in marginalia","id":"CVE-2019-1010191","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"sql_injection","year":"2019"},"n_packages":2,"n_references":1,"next":{"headline":"Cross-site scripting in hisiphp","id":"CVE-2019-1010193"},"packages":[{"ecosystem":"RubyGems","fixed":["1.6"],"introduced":["0"],"last_affected":[],"package":"marginalia","purl":null,"source":"GHSA-hrj5-qp7x-rpg6"},{"ecosystem":"RubyGems","fixed":["1.6"],"introduced":["0"],"last_affected":[],"package":"marginalia","purl":"pkg:gem/marginalia","source":"GHSA-hrj5-qp7x-rpg6"}],"prev":{"headline":"Denial of service in mgetty","id":"CVE-2019-1010190"},"products":["marginalia"],"published":"2019-07-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["marginalia"]},"summary":"Attackers can inject arbitrary SQL queries via user-controlled arguments in the marginalia Ruby library, potentially accessing or modifying database contents.","url":"https://insights.sbomify.com/CVE-2019-1010191/"}