# CVE-2019-1010191: SQL Injection in marginalia

> Attackers can inject arbitrary SQL queries via user-controlled arguments in the marginalia Ruby library, potentially accessing or modifying database contents.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Jul 2019
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-hrj5-qp7x-rpg6

## What is CVE-2019-1010191?

CVE-2019-1010191 is a critical SQL injection vulnerability in marginalia, published on 24 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

marginalia < 1.6 is affected by: SQL Injection. The impact is: The impact is a injection of any SQL queries when a user controller argument is added as a component. The component is: Affects users that add a component that is user controller, for instance a parameter or a header. The attack vector is: Hacker inputs a SQL to a vulnerable vector(header, http parameter, etc). The fixed version is: 1.6.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2019-1010191?

2 open source packages ship an affected version, including marginalia. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `marginalia` | RubyGems | All versions | 1.6 |
| `marginalia` | RubyGems | All versions | 1.6 |

Products: Marginalia Project Marginalia.

## How do I fix CVE-2019-1010191?

Upgrade marginalia to 1.6 or later.

## Is CVE-2019-1010191 being exploited?

There is no known exploitation of CVE-2019-1010191 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2019-1010191 and fix it if it is affected.

What it is: CVE-2019-1010191 is a critical SQL injection vulnerability in marginalia, published on 24 Jul 2019. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2019-1010191 in the wild and no public exploit code.

Affected packages and fixed versions:
- marginalia (RubyGems): affected all versions; fixed in 1.6
- marginalia (RubyGems): affected all versions; fixed in 1.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2019-1010191/ (Markdown: https://insights.sbomify.com/CVE-2019-1010191/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2019-1010191
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2019-1010191
- OSV: https://osv.dev/vulnerability/CVE-2019-1010191

---
From sbomify Insights: https://insights.sbomify.com/CVE-2019-1010191/
Summaries are generated and may contain mistakes; the official description above is the record.
