CVE-2019-1010247 Cross-site scripting in mod auth openidc

Medium 6.1 Published Updated

Cross-site scripting vulnerability in mod_auth_openidc allows attackers to redirect users to phishing pages or interact with the application on their behalf.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2019-1010247?

CVE-2019-1010247 is a medium-severity cross-site scripting vulnerability in ZmartZone IAM mod_auth_openidc, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

ZmartZone IAM mod_auth_openidc 2.3.10.1 and earlier is affected by: Cross Site Scripting (XSS). The impact is: Redirecting the user to a phishing page or interacting with the application on behalf of the user. The component is: File: src/mod_auth_openidc.c, Line: 3109. The fixed version is: 2.3.10.2.

Weakness: CWE-79

Which versions are affected by CVE-2019-1010247?

It affects 1 product.

Products include Openidc Mod Auth Openidc.

How do I fix CVE-2019-1010247?

Upgrade to a fixed version.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2019-1010247 being exploited?

There is no known exploitation of CVE-2019-1010247 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2019-1010247, DLA-1894-1, GHSA-xp9w-hvv3-f7rw, UBUNTU-CVE-2019-1010247.

Is CVE-2019-1010247 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free