{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2019-1010247 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2019-1010247 is a medium-severity cross-site scripting vulnerability in ZmartZone IAM mod_auth_openidc, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2019-1010247 and fix it if it is affected.\n\nWhat it is: CVE-2019-1010247 is a medium-severity cross-site scripting vulnerability in ZmartZone IAM mod_auth_openidc, published on 19 Jul 2019. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2019-1010247 in the wild and no public exploit code.\n\nAffected product: ZmartZone IAM mod_auth_openidc. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2019-1010247/ (Markdown: https://insights.sbomify.com/CVE-2019-1010247/index.md)","id":"CVE-2019-1010247","markdown":"https://insights.sbomify.com/CVE-2019-1010247/index.md","name":"CVE-2019-1010247","record":{"aliases":["DEBIAN-CVE-2019-1010247","DLA-1894-1","GHSA-xp9w-hvv3-f7rw","UBUNTU-CVE-2019-1010247"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache OpenID Connect module","requires_auth":"none","summary":"Cross-site scripting vulnerability in mod_auth_openidc allows attackers to redirect users to phishing pages or interact with the application on their behalf.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"dwf","cpe":[{"product":"mod_auth_openidc","vendor":"openidc"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ZmartZone IAM mod_auth_openidc 2.3.10.1 and earlier is affected by: Cross Site Scripting (XSS). The impact is: Redirecting the user to a phishing page or interacting with the application on behalf of the user. The component is: File: src/mod_auth_openidc.c, Line: 3109. The fixed version is: 2.3.10.2.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting in mod auth openidc","id":"CVE-2019-1010247","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2019"},"n_packages":0,"n_references":5,"next":{"headline":"SQL injection in I-doit","id":"CVE-2019-1010248"},"packages":[],"prev":{"headline":"Information disclosure in MailCleaner","id":"CVE-2019-1010246"},"products":["mod_auth_openidc"],"published":"2019-07-19","related":[{"cvss_score":8.6,"headline":"Auth bypass in n/a","id":"CVE-2017-6062","kev_date_added":null,"published":"2017-03-02"},{"cvss_score":8.6,"headline":"The \"OpenID Connect Relying Party and OAuth 2.0 Resource Server\" (aka mod_auth_openidc) module before 2.1.6 for the Apache HTTP Server does","id":"CVE-2017-6413","kev_date_added":null,"published":"2017-03-02"},{"cvss_score":7.5,"headline":"mod_auth_openidc core dump when OIDCStripCookies is set and an empty Cookie header is supplied","id":"CVE-2023-28625","kev_date_added":null,"published":"2023-04-03"},{"cvss_score":7.5,"headline":"Open redirect in n/a","id":"CVE-2017-6059","kev_date_added":null,"published":"2017-04-12"},{"cvss_score":5.8,"headline":"Open redirect in mod auth openidc","id":"CVE-2019-14857","kev_date_added":null,"published":"2019-11-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["ZmartZone IAM"]},"summary":"Cross-site scripting vulnerability in mod_auth_openidc allows attackers to redirect users to phishing pages or interact with the application on their behalf.","url":"https://insights.sbomify.com/CVE-2019-1010247/"}